Support Topics Documentation Slack YouTube Blog

Import of data file hangs

Hi Guys.

Console will not import some users into app from Users.csv file. can you take a look please. I have imported data like this in the past successfully, but when I try to import the file backendless console seems to just hang indefinitely.

File is in my Files directory Files/import/Users.csv (45.00 KB)

I need to import this urgently as migrating data today.

Mike

Hi, Mike.
I’ve looked at you file and found out that it has only 50 users. The rows after 52 are invalid records, because they don’t have any column values, even objectId is missed.
Have you changed this file manually or maybe with some script, or it was received just with export ?

Hi Oleg

Thanks, Yes I just noticed the invalid records too.

I only wanted to import a subset of users so I exported the file from Backendless and then deleted the users I didn’t want. I see it saved some blank rows afterwards however.

I have cleaned up that file (19.00kb) so it has no invalid recored and tried to import again , but it still won’t import.

MIke

I’ve tried with you last version of Users.csv. And all 50 users were imported successfully. I checked on a new app. Can i try on your app ?

Yes sure go ahead and try, thanks.

We’ve managed to reproduce the problem. It is already been fixing.

Everything should work fine, please check (do not forget to refresh the backendless web-console page).

1 Like

Confirmed, import successful.

Many thanks for your help Oleg.

Mike