Support Topics Documentation Slack YouTube Blog

Internal Backendless Error

Application ID: 91B1BBBC-51BA-F6F3-FFC0-EDF5487CA600

Oops. An internal error [ccf3123bde89e04976fca179610357b6] has occurred. We are working on it. Please try again later

Problem description

Describe what you did in console that led to the error. Please provide a description of what actually happens. Be descriptive: “it doesn’t work” does not describe what the behavior actually is. This will help us with reproducing the problem.

Steps to reproduce

Please describe steps to reproduce starting from the first action.

  1. This started happening after I tried to duplicate a method by deploying the method in the same service
  2. Now I cannot create any method in that service or update the business logic for any method in that service

Hi @Arnold_N,

try to redeploy your services (without duplicated method). If this will not help, please specify service name.

Regards,
Stanislaw

Yes I tried that and it didnt work. The service name is “backendemployers”

Is there any quick fix. I’d appreciate your help. Thanks

We will look into it, but please do not use the functions for renaming methods, services or creating duplicates of methods. We are aware there are problems in this area and it seems you keep running into the same issue over and over again.

Thanks will do!

Please describe what you copied where? I need to understand what led to this so we can try to “unwind” it back.

  1. I created a method called “UpdateRating” in the service “backendemployers”
  2. I then opened and built the logic
  3. I deployed it succesfully
  4. I then wanted to create a similar method so I used the “Deploy to another codeless service button” but I selected the same service “backendemployers”
  5. It succesffuly deployed, but then after that I could no longer deploy any method in the entire service

I restored the service, there are two methods now: GetApplicationsByInterviewId and UpdateRating. I think there was a third method, but I do not see what the signature of it was. Please check.

Yes i can’t see my third method “GetInterviewsByAccessToken”. Please restore it as well. Thank you

I need to know what the signature of that method is. Specifically: what arguments it accepts, argument types, Route URL, etc.

It has no arguments. Here is the url https://api.backendless.com/91B1BBBC-51BA-F6F3-FFC0-EDF5487CA600/AEDD5C9F-4F55-40D2-9A59-AAE1A7DADD32/services/backendemployers/interviews

It requires the header “temporaryAccessToken”

Backendless doesn’t support “required” headers. Can you clarify what you mean?

@Arnold_N, the method is now there. Please check and confirm.

Thanks @mark-piller its working now

Hi @mark-piller I think when you were restoring the service yesterday you affected on of my other services called “backend”. I can’t find it. It’s just disappeared. Please help

Hello @Arnold_N

The service has been restored

Regards, Vlad

Thanks @vladimir-upirov