Invalid GIS data provided - Looks related to new Backendless jar version

Hi Team,

I noticed when deploying cloud code which updated an object that contains a POINT it results in the following error:

400 - Invalid GIS data provided. Correct string with WKT or string with GeoJSON or just GeoJSON object is required. (1312)

What was strange is the function worked fine when I ran via coderunner, I then noticed my Backendless.jar file was a few months old, I updated to the new one and now I’m getting the same error in coderunner.
To repo:
Create a table with two columns, one String ‘name’ another POINT ‘location’. Create a dummy row with a POINT location (Example point for input into the console: POINT (79.90613134797755 6.720792682218309)) and a dummy name, then create the following cloud code with the latest backendless jar

In your java code in the cloud.
TABLENAME myObj= Backendless.Data.of(TABLENAME .class).findById(object_id, 0);
myObj.setName(“New Name”);;

On save you should get the same error.

Hi, @Reece_Smith

We have created an internal ticket BKNDLSS-24473 for your case. We will investigate the issue, and fix it in the nearest releases.

Regards, Marina

Thanks Marina, please could you add priority onto the ticket as it will impact all customer cloud code which has POINT data on.


This ticket has a high priority. We will try to fix this problem in the near future.


1 Like

Hi @Reece_Smith

We’ve released the new version of Backendless. Please, can you check if this issue is resolved?

Best Regards,

Looks good, thanks guys.

Glad to here it!

Happy coding with Backendless :slight_smile: