isNaN / invalid date data validation

Hie guy am trying to do data validation that if the user doesn’t pick a date the system identifies that the date is not entered and throws an error. Please help.


Hello @Dalubuhle_Lunga

Could you please add more details and describe the context where you need it

Regards, Vlad

I set the date selected to print on console. If the use picks a date it displays the date, however, if they dont it says invalid date as shown on the second screenshot of the browser console

i want to be able to manipulate it like the fish amount if nothing is entered on it am able to print the message “very wrong so far” if the user enters data it prints “nothing wrong so far”

could you please print dateadded value? how does it look like?

It says “invalid date”

no, there is another block between the Print and Get Property blocks

I removed it let me send screenshot

This is after removing the block and disabling it.

ok, where does this value come from?

could you please create a test page with minimum UI Elements and Logic to demonstrate the issue?

Ok no problem


Ok seems i might have the value being changed else where. Let me try to find where exactly. Thanks.

Hi Vlad,

I tried to assist here by printing the dateadded value but I’m getting the same error. I disabled everything else on the page and I’m left with this only:

When I submit with no date selected in the datepicker, I of course get the undefined result:

But what is confusing, is when I select a date and run a submit again, I get exactly the same undefined result.

I checked the data binding, that the datepicker was in the form and even tried to print the label of the datepicker instead of the value itself and still only get undefined.

Application ID:

Container: Main
Page: Capture-Fish-Data

Please advise what we should do. It seems that something is broken beyond what we can see on the Frontend

Hi @Armandt_du_Preez,

could you please?
It will narrow down the problem.


Hi Stanislaw,

When @Dalubuhle_Lunga and I both logged out and logged back in then the functions started to work again.

Thank you

Hi, @Armandt_du_Preez

Do you still have the issue? Or has it been solved?


It has been solved