Issue with a Pre-installed service on Backendless

Hi Team:

I have been using a pre-installed service on Backendless (Sharp library for image processing).
It was a small piece of java code that I am using to put some text on an image.

It has been working fine for a few months now.
It last worked fine on 25th Oct.
From 26th Oct, the service is not able to put text properly on the image.

No update to the piece of code from my end.

I am attaching two images that will help explain my problem.
Before 26th - the bottom right text is correctly put on the image.

Post 26th - the bottom right text is gibberish

My question is has there been any update done to this service (sharp) that is pre-installed at your end… any update around that date to the lib… any inputs… workarounds…

please help as this is impacting me in production.
appreciate any thoughts.

pls note that the library as such is working because it is able to use the font color as input to the library… just the text is gibberish…

any update to the default font file?
(I had been using the default font)

Hi @Achilles_Pereira

Thank you for reporting the issue,
No, we haven’t changed the version of the sharp module, it’s still

 "sharp": "0.30.7"

However, we upgraded Nodejs in CloudCode env from 14.x to 18.x, so perhaps it could be the issue

could you please share a minimum code sample to reproduce the issue?

Regards, Vlad

Thank you @vladimir-upirov for your response.

I think you are right…
I have had issues with getting any specific font earlier, so I relied on default font that the library generated as it was ok…

But, since 26th, only Gibberish…
I have tried to make it easy for you below but I am not sure if I have complicated instead…
(I am primarily a codeless programmer with a bit of js only when unavoidable)

My application ID is 0B6BE4AB-12E6-4BF7-FF0C-CDFE694EF000

I have created a service FHSharpTestLib in js with a method that takes a white image and tries to write two lines over a colored background with different font colors.

Here is the sample code with the test service.
testsharp.js.txt (2.2 KB)

I call the service thru a timer.

You can invoke the timer and the path of the file created is printed on console.

Please reach out for any clarification.
Appreciate your support.!

I would greatly appreciate an indicative time for the root cause analysis.
This will help me in my communication to my clients.

These posts are my primary deliverable.

Hi @vladimir-upirov

I hope you get time to have a quick look at this…
I have a production-down kind of crisis…

A few more analysis points the root cause towards the nodeJS upgrade.

Test Code to get 2 texts of text over a white image:

The code is able to output the two texts properly over the console log as below:

But, the output file (via composite call of sharp lib), the font file is not found.
Note that the font color is applied correctly. It is not a sharp lib issue. It is just unable to find font.

All of this was working well prior to Oct 26th.
Please help!

Achilles Pereira.


Here is the updated test code file.
testsharp_updated.js.txt (2.5 KB)

Kindly let me know if there is any other input that might be helpful.

Achilles Pereira


Apologies for the multiple replies.
Just sharing a couple of links that point towards setting up environment for fonts required by the sharp library.

1.font installation note at sharp lib

  1. librsvg uses fontconfig, which can be controlled via environment variables and config files - see fonts-conf

3.a short post about how to fix it here:

While these point at custom fonts, I will be very happy with ANY default font that can be rendered on the image.

Please help!

Hi @Achilles_Pereira

The investigation is still in progress, we notify you here once we have any update.
Thanks for the additional information!


Thank you @vladimir-upirov for your quick response.


We were able to reproduce the issue and fix it.
Once our QA checks it we release it to the prod and notify you here on the topic.



Hello @Achilles_Pereira

We’ve just updated cloud servers with a fix for the issue you described above. Could you kindly let us know whether fix works for you well?


Thank you @Inna_Shkolnaya .
The fix works for me.

Thank you for the quick work.