Issue with Minimum and Maximum Dates in Date Picker


I am having some trouble with the minimum and maximum date logics in the date picker component.

These used to work since they have been introduced but somehow lately they seem to not work anymore (a build I made a few weeks back is working fine).

On my app (ID D7075715-5086-625A-FFAB-39C2F40FB200), I prepared a page : test_date_picker .

There you can reproduce the fact that I set a reference date and then try to use it in a second and third date picker.

I manage to set whichever date I want without any constraint.


Perhaps a recent regression ?

Thanks for your feedback.

Hi. I’ve created the internal ticket for investigation.

1 Like

Hello @Nicolas_REMY

Is the problem still reproducing?


I tried testing it, but I get a different type of error in my app : it looks as though something has changed in the SDK and causes this issue :


Hello @Nicolas_REMY

Looks like you try to get property from null.
Do you have some logic like this:

You expect that the “someData” has the property “clone” but the “someData” is null


I understand this type of error. Except that if you look closer into it, this isn’t in my UI builder code. I have no “clone” property anywhere in my code. This error happens in ui-component_date-time-picker.js . Or am I mistaken ?

You are right, my fault, the error occurs in the component.
This error occurs with your Ref, Min, Max date pickers (from the first message)?
Can you provide us with your app ID, container name, page name to debug this error?
It would be great if you could make a simple demo page with this error.


I don’t have the test_date_picker page anymore : it was a while ago and it would have overloaded my app to keep it there.

So I have tried rebuilding it, but can’t manage to reproduce the error. Perhaps it was something in cache or else. If it happens again I will chime back in here.

Hi @Nicolas_REMY,

If you have such an issue in the future, please let us know and we will look into it.


Just to close this issue, it looks as though it is not the case anymore. The regression has been corrected at some point.