Issue with table

I am unable to access my table “Doctorlist” after i tried to add a string column “location” in the tabe schema.
Please help.

App id 55F928E7-9D6E-937F-FF72-80924AE09B00

Also getting this error while trying to delete “location” column.

Internal Error

Backendless encountered an error while handling the request.
We logged this error with ID 29E00FA4-A9E8-C02A-FFB1-0F8B358B9D00 and will be investigating the issue.

I see the error.
Could you clarify, the problem appeared after you add column manually or after import/export operations ?

If it was the import, could you delete and reimport this table again?

The problem can also be solved by deleting the column. So i would like you to try to reimport it at first.

I added the column manually. I tried deleting the column location but it is giving me an error

I tried exporting the current table but i am not getting any data. I have backup but its from few days ago. So deleting the table and importing from my backup of that table should be the last option to correct the error. Please try and correct the error from your side. If you can give me the export of the current table, i can try deleting the table and importing. Point is i have few days old data, so if you could, please provide me the current table data and i can follow your steps.

Please check. The problem was fixed.

1 Like

Thanks Oleg.

Same issue when i tried to add a column. Is there a limit to column adds?

Please delete column locationyn.


Should i try adding a column now?

Yes. I added and deleted tmp column in order to check. Everything should work now.
Also recommend to normalize the structure of your db, because up to 40-50 columns in one table sounds like too mach.

Same issue is coming up. I add and an error comes up and then i cant access it

I can delete few of the columns which i dont need and then try adding new column. I get your point and i can reduce many columns now. Request you to delete the column again. I will try adding column with different name i guess.

Could you do one thing? Add a column locationyn with datatype as String from your side for the time being. I assume, with the ongoing coronavirus issue, there might be fewer people to help you resolve this issue. Just add this column for me. I will not me making any column changes after that for sometime.

Yes. I noticed it.
Now I’m trying to solve this problem.
The inner task [BKNDLSS-20963] was created.

1 Like

p.s. the limit for the columns amount is restricted by the underlying database (in our case - mysql) and you faced with such a limit. So, the correct error message will be thrown after fix. But it also means that you need to review and change the structure of the table, as i wrote before.

1 Like

Ok Oleg. I will remove many unnecessary columns after i roll out new update for the application in 1-2 days. Thanks for the help!

As an advise: it is also a good approach to limit the column size to the really needed size according to you data. It has influence on performance and the total amount of columns.

Will do :slightly_smiling_face: