Issue with the Email setup

I am trying to use my email on the Email Settings on Backendless where I’d have to set up my SMPT server and port. I have the configurations for both secured ssl/tls and non secured configurations.

  • For some reason, when I fill the Email Settings form with the non secured configurations and press on “Test”, it says “Test passed”, but when I try to “Save” this I get a red pop up that says “Could not convert socket to TLS”

  • So I change the radio button from TLS to SSL and then press “Save”. I get a red pop up that says “Could not connect to SMTP host:, port: 587”

  • Alright, so now I fill the email settings form with the secured SSL/TLS configuration. With the TLS radio button checked I get the same “Could not convert socket to TLS” when I press on “Save”. However, if I select the SSL radio button and press “Save”, I get a loading screen that never seems to end.

For all the above the “Test” says “Test Passed”. All the port numbers, servers and credentials are correct. My email servers came with the hosting servers offered by inMotion Hosting. The email works well everywhere else (especially other MBaaS and APIs). So…why can’t I use my email on Backendless?

Funny thing, I used my gmail account beforehand, which used to work with Backendless. Then oddly, it just stopped.

Hello, Salman!
Please provide your application id.

I’ve opened an internal ticket to investigate your issue. We shall contact you if we need more details. For reference, ticket id is BKNDLSS-13700.
Thank you for your patience!
Alex Navara


Here is my application ID. Sure, that would be greatly appreciated.

We would need a test account in your mail server which we can test with. Please create an account and email all settings (hostname, port, userid, password, etc) to



Hello, Salman!

I wanted to notify you that we’ve made a fix for this issue. Now it should work with non-secured configuration by TLS and with secured configuration by SSL. Please, check it on your app and notify us about results.

Hey Alexandr,

So I just tested it on secured configuration by SSL, I still get that red notification on top that says “Cannot convert socket to TLS”. I’m pretty sure I got all the details and credentials right.

I tried a non-secured configuration by TLS set up, I got an “Email setting saved message in green on top”. However on refreshing the settings page, the userID and password reverts to the one I’m logged in on Backendless.

BUT it works. I got an email working from the email I intended to save and use.

okay so I was using the email regularly, was working fine. Until I got this on my console.</img>

This is a JS Backendless API calling on to an update. There is a CodeRunner in the back running a before update trigger, this bit sends an Email using Backendless. Any idea why is that happening out of the blue? Can’t have this going live like this.

P.S I’m using the non-secured configuration by TLS.