Keep getting error: 404 "Outcode Not Found" when trying to update user properties Via REST API

Backendless Version (3.x / 5.x, Online / Managed / Pro )

6.5.2 Cloud

Client SDK (REST / Android / Objective-C / Swift / JS )


Application ID


Expected Behavior

Please describe the expected behavior of the issue, starting from the first action.

  1. Update User

Actual Behavior

Please provide a description of what actually happens, working from the same starting point.

Be descriptive: “it doesn’t work” does not describe what the behavior actually is – instead, say “the request returns a 400 error with message XXX”. Copy and paste your logs, and include any URLs.

  1. Status Error 404: Outcode Not Found

Reproducible Test Case

Please provide a simple code that could be run in a new clean app and reproduce the issue.{api}/data/Users


  • Content-Type: Application/Json
  • user-token

PUT Request

Hello I’m pretty sure this used to be working but now I seem to keep getting this error and I’m not sure why.

Thank you


Please take a look at the documentation for the object update API:

You will see that the URL has the following format:<table-name>/<objectId> 

in the format you’re using, it should be:<table-name>/<objectId> 

What’s missing is the <objectId> value at the end of the URL.

It is also not clear from your description if you’re sending a JSON in the body of the request. I assume you have it there.



Yeah I am putting the objectId at the end but I get the same error.

I’m using AppGyver, just a simple update to first and last name properties.

I tried updating a different table and it worked fine so I’m thinking maybe there’s something specific to the Users table that I’m not getting right ?

I have read the documentation, I’ve also updated user properties before but I’ve never saw this error up until recently.

Thank yuo

Try this API instead: