Support Topics Documentation Slack YouTube Blog

Log error!

Hi, I suddenly got some “has been blocked by CORS policy” errors. That we did not have before. And the log system id totally stopped. Can you check that?
app_id 322E4DE2-BCCF-92E1-FFE6-1EEEE1C30A00, on manages server.

In our app we have created separate Logger. But none of them works. Lastly we had some different problems with the Log management system! Some times is take a long time to run real time logging!

hello, according to loggers, make sure that you configured log level correctly, you can check it in Manage -> Log Management

according to CORS, please provide us steps to reproduce the issue

the “Application-wide log level:” is on “INFO” level. Other individual loggers are in “INFO” level too.

According to loggers, It seems that I needed to chose the level again to “INFO”, even though it was on “INFO”, then it runs correctly.

as I can see in the app, not all logger categories have “INFO”, some of them is “OFF”

Yes some of them. Because I do not need all of them.

ok, so problem with loggers is gone, isn’t it? =)

We are using some external API. I mean we send some http request to an external domain. All was working great until about cl. 09:30 today morning. I have no idea why I got that. I am still investigating our code!

Yes, It seems like that.

I tried to switch to “OFF”, but it still pushing logs to
REAL-TIME LOGGING

image
You now this refresh button on the files page. It does not work.

if we talk about “pended_…” there are no messages of the category anymore, I believe it applies not immediately, it may take some time

You now this refresh button on the files page. It does not work.

why do you think so?

try to check response http headers for that request to an external server

It seems it works now. Maybe I just was wrong. I was talking about the refresh button!

Before I do that can you check this logger “currentRMS_” ? I can not get any logs fro it!

may I send some test log message using REST api to check that?

Yes no problem