Migrate Parse users with Facebook


My problem is when I import Parse export zip file it creates an “authData” field for users who were registered using Facebook and does not set the “socialAccount” field so these users can’t login in and signing in with facebook creates a new user.
Here’s a sample from Users.json

“authData”: {
“facebook”: {
“access_token”: “CAAGZAvSGbi5YBAIMniQ11lZCaettP6R3k9l2ybdOHo3NBH4oqQdXqPp7IKeIJq160ojx6HzKlfwgk5rUiqXSkZBTmdlzWaVpKETOZB4HBHGBZAZC0mIWzslrXrfGoIgRNOu89yqOtI7qJsJazjZBN6EcYrPzw7O7MbYOzRjfDsbBapz3k2QHCmecVLHvaZCqpmGYlZCEP79Rt2KbIl39ZC8MgqHtgKbhrU2nsZD”,
“expiration_date”: “2016-05-03T12:11:21.635Z”,
“id”: “573086672849623”
“bcryptPassword”: “$2a$10$ainl2pK/cifXHnpZw/zbduZTclwHQZhvWYGOTTX9oqdPUAR46WX/6”,
“createdAt”: “2016-03-04T12:11:22.805Z”,
“firstName”: “Ian”,
“lastName”: “Adcock”,
“objectId”: “Owo63KuDVx”,
“photo”: {
“__type”: “File”,
“name”: “tfss-66b87a7f-2b3b-4531-95f8-7988dfbfafe6-file”,
“url”: “http://files.parsetfss.com/7a49b015-3379-4793-918a-9aff4e65b9c9/tfss-66b87a7f-2b3b-4531-95f8-7988dfbfafe6-file
“rateCounter”: 1,
“sessionToken”: “dNKY6V0IppdudRRvYvl5rM4UO”,
“updatedAt”: “2016-03-04T21:38:06.366Z”,
“username”: “TpVkk2mlhNGmoxqqHlyDyHbiT”

In Backendless it looks like in the attachment.

Hi Adam,

Internal ticket with id 12740 has been created for this issue.



Hi Denys,

Any update on this issue? My client would like to propagate the migration so it’s getting urgent.


Please wait several days. We will update production server on this week.

Kate, it’s been a week. I need urgent solution, this problem is a blocker to migrate my client’s app!

Hi, Adam. This issue is fixed. But the next release will be in 2 weeks so please plan accordingly.

Hey Anatolii, this is great news! Thanks for the heads up. Do you have a schedule for the deployment? I need to test it before my client can notify his users.

I assume it hasn’t been deployed yet since I’m still having this problem with importing. Any schedule?

estimated date is 19 July

Guys, just tried today and no luck: a property called “authData” is still created with raw json content while “socialAccount” is nil. This is getting very urgent now, my client’s app needs to be submitted ASAP and this is a critical blocker. Please tell me this is getting fixed soon!

Hi, I’m still waiting for a solution. Any updates? The release rolled out on the 19th is no help.

So, anything happened lately? My last imports worked perfectly today!

We have upgraded Backendless server on 25 July, I believe it fix the problem.

That makes sense, thanks. Hope it remains like this. Thanks for the heads up!