Missing boundary header 400 File Upload

App ID: D3828E7D-B42E-B69F-FFFC-EFE55E612400

Hi guys

I’ve been trying to upload images to Backendless Files. I use Thunkable web API blocks like below
image
The upPhotoAPI has header Content-Type: multipart/form-data.

However, I keep getting this error: code: 8002, message: Could not parse request with message: Missing boundart header, status code 400, headers POST / App-id / secret-id / files / path / xxx.jpg?overwrite=true, errorData: {}

I’ve searched around the forum and I’ve tried their suggestions like using prefixes as https://backendlessappcontent.com or https://eu.backendlessappcontent.com or https://api.backendless.com, but I just keep getting the same error.

Can someone explain where the error is? Thanks!

Hi @Louis_Cadier ,

this error means that the Content-Type header is still not sent. Try to make sure your API is actually sending Content-Type: multipart/form-data.

Regards,
Stanislaw

Hi @stanislaw.grin

The header is correctly set, it is only Content-Type: multipart/form-data right? What else info need to be added? With just url and header the api doesn’t seem to work. Any info to be added in the body and query parameter parts? Thanks!

I have made a simple example of uploading file using Backendless API.
Please try it out with your App ID and API key and let me know if it works for you

https://jsfiddle.net/n8he652p/

I see the forma data part but I’m afraid with Thunkable blocks there is no block for that info:( Well I’ll try it with Cloudinary since they have a customed block with Thunkable, then I’ll transfer the url to backendless. Thanks anyway:)

You’re welcome!