Support Topics Documentation Slack YouTube Blog

Mission Not completing (retrieve related data with api)

Mission: RELATIONS MASTER
Task: Retrieve Related Data With API

I’ve done the task exactly as in the video, I’m getting name and cityOfResidence in the same block, but the mission is not completing. I tried switching it to city0fResidence because the documentation looks a little wonky that way and that didn’t work. I even deleted the age column thinking that was it, but nothing worked.

The fields are related, the table names are correct as are the reference fields, but the mission doesn’t show complete. I’ll Add screenshots in a minute.

Honestly, it doesn’t bother me that I can’t get the mission to complete beyond the fact that I can’t access the next series of data missions until it does. This section has been the most helpful for learning what I need for the app we’re building so I’m sure the next section will have even more I can use to make it easier. Thanks!

Hi @Frank_Piotrkowski ,

please change a pageSize option to different from 1, then try again.
This is a known issue that will be fixed soon.

Regards,
Stanislaw

Worked perfectly. Thanks!