Mission not showing as complete

Task: Add a location (POINT) to a data object using console

I have completed this mission. I have deleted the point, re-added it, deleted it, re-added it. I have added points for every capital city in the table, the mission will still not show as complete. This is not the first time I have had a problem with missions not showing as complete. I had the same problem with Codeless Crud and then a similar problem with not getting the thumbs-up icon on File Manager. Looking at other posts it seems to be a common complaint, one that really should be looked into and fixed if you don’t want people to lose interest and go find some other platform to use.

Hello @Dawn_Louise_Howson,

I looked at the logs and the current state of your missions. I see that you completed this task 06/03/2021 at 10:25. Have you received a pop-up notification about the successful completion of the task?

I want to draw your attention to the fact that at the moment the mission map is not updated in real-time, but we will definitely fix it.
So far, in order to see the changes in the mission map, you need to refresh the page.
I know it uncomfortable and annoying for you, we are working to make everything happen as smoothly and as easy as possible for you.


I have had no pop up notification for completing the task. Not only have I refreshed the page with the refresh button, I have also refreshed the page while holding the CTRL key to force the page to load fresh. I have also closed and reopened my browser. I have also turned off my laptop for a few hours then come back to it.
It is still showing as incomplete and I still cannot move on to the next mission.

I have also just used my browser settings to clear my browsing history and cache, the mission is still not showing as complete.

Hi @Dawn_Louise_Howson,

do not worry, your efforts will not be in vain, we will take into account your progress in any case. We are sorry that you are upset with your learning experience through our missions, we apologize. Please update your console and check if you can progress further. Thank you for your patience!


Hello @stanislaw.grin . I have the exact same issue on app id C97E7B60-9A02-278E-FFEB-5818D5D8D100

I have done everything but it does not show the mission as complete…

Thank you

Edit: the first mission on Geo set : import sample spatial data etc…

Hello @Loukas_Ioannidis,

welcome to our community!

Could you repeat the task and make a screen video of how you do it?
Is there a chance you made a typo when renaming a column from “loc” to “location”?


I have checked in your app, you have missed the 11th and 12th steps of the task:

  1. Pay attention to the loc column, see what data type of the column is.
  2. Click the cell with the column name and rename the column to location.


I was changing the name of the column “name” to location, not the column “loc” to location which is the needed step…

Thank you very much for the very quick response