Network Error when attempting to go thorugh 2nd Mission in Serverless 101

First and third missions seem to operate as expected. When hovering over link to 2nd video, the Network Error pops up. I can navigate to that video directly in YouTube.

Hello @Alex_Horton

Can I ask you to open Devtools(usually it’s F12 key) - tab Network - click on red record and make a screenshot with an error.

Thank you for informing us about this issue.

Regards, Dima.

Sure! Here you go! Looks like a CORS issue…

Anything yet?

Bump :slight_smile:


Can you try using Chrome?

Here instructions for this task:

With this task you will be invoking an API service from a client application using an SDK generated by Backendless.
This task will be marked as complete when you invoke the following methods on the CodelessShoppingCartService :

  1. Invoke the getInstructions() API service method.
  2. Invoke the addItem() API service method.
  3. Invoke the getItems() API service method.
  4. Invoke the purchase() API service method.

It is important that the methods are invoked in the same order as described above. After invoking the purchase() method, you should see the Order table created in the database. You can use any client-side environment which can work with the code generated by Backendless. The video below demonstrates how to perform the task for JavaScript and you are welcome to follow it, however, you are not required to use JavaScript.


Chrome Screenshot - same result:

I’ve already completed the task. I did that when I watched the video directly from Youtube.

If it helps, here are all of the troubleshooting steps I have tried:

  1. Clearing browser caches, both Chrome and Firefox
  2. Restarting PC
  3. Logging out and back into Backendless
  4. Ensuring that JS support is still turned on in browsers.

This is the only mission step that is erroring.

Hi @Alex_Horton,

thanks for details.
I tried to reproduce it many times in different environments with no luck.
Any chance you have some browser extensions that might block this request for some reason?
I see you have Tampermonkey in Chrome, maybe you have something in Firefox too.
Also I see two different errors on your screenshot - in FF it’s saying about CORS and in Chrome - net::ERR_CONNECTION_RESET, which indicates that something on your computer, network or browser caused the connection to be interrupted and reset.


Found the issue. Blasted anti-virus!

Thank you very much, sorry for the hassle!