New users cannot register: "Error: User has no permission to add relation for the current table"

Application ID


Earlier today I was trying to modify permissions of the Users table (as by default it’s completely wide open), until I reached a certain point that it gave me this error when trying to register a new account to test:

15:13:42.903 | SERVER_CODE | ERROR | [23736] Error: User has no permission to add relation for the current table. at new ResponseError (/usr/local/lib/node_modules/backendless-coderunner/node_modules/backendless-request/lib/index.js:42:116) at checkStatus (/usr/local/lib/node_modules/backendless-coderunner/node_modules/backendless-request/lib/index.js:237:9) at processTicksAndRejections (internal/process/task_queues.js:95:5)

In an attempt to debug it, I reset the permissions back to default and yet I get the same error. I’ve also tried opening wide any tables that I thought relevant to the Users table and registration process, same error.

Unfortunately the error it gives doesn’t really tell me much about where the issue is or what table(s) it’s trying to add relations to, so I’m not really sure where to go from here.

Any help is very much appreciated,


Update: I’m not really sure why, but I tried signing into an account already created and it seems to have fixed itself… I’m guessing I triggered some kind of weird edge-case bug with Backendless’ UserService.

If I have any other relevant issues I’ll make another reply

Hello @Nathan_Cousins

Do you have any problems now with user registrations?


Hello, @viktor.liablin,

The problem seems to have gone away, registration and signing in continue to work as intended. I’ll update this thread if it misbehaves again.