No error. But App crashes.

I’m using Android studio. And I use my phone to test my app(kitkat). Has no error but crashes as you open it.
Trying to show list of directories into listview.

protected void onCreate(Bundle savedInstanceState) {
 Backendless.initApp(this, Defaults.APPLICATION_ID, Defaults.SECRET_KEY, Defaults.VERSION);

 Backendless.Files.listing("/Uploads", "*docs", true, new AsyncCallback<BackendlessCollection<FileInfo>>() {
 public void handleResponse(BackendlessCollection<FileInfo> fileInfoBackendlessCollection) {
 Iterator<FileInfo> filesIterator = fileInfoBackendlessCollection.getCurrentPage().iterator();
 while (filesIterator.hasNext()) {
 FileInfo file =;
 String URL = file.getURL();
 String publicURL = file.getPublicUrl();
 Date createdOn = new Date(file.getCreatedOn());
 String name = file.getName();

 String[] info = {URL, publicURL, name};
 ArrayAdapter<String> adapter = new ArrayAdapter<String>(getListView().getContext(), android.R.layout.simple_list_item_1, info);


 public void handleFault(BackendlessFault backendlessFault) {



Please help.

Have you tried debugging it? For instance setting breakpoints before you make the API call and in the responseHandler and see if they are hit?

I have tried debugging it and setting a line breakpoint in initApp and HandleResponse. But I dont know what im looking at. My logcat says this is the error why the activity was unalble to start:

5100-5100/com.example.francis.classdroidapp E/AndroidRuntime: java.lang.RuntimeException: Unable to start activity ComponentInfo{com.example.francis.classdroidapp/com.example.francis.classdroidapp.MainActivity}: java.lang.RuntimeException: Your content must have a ListView whose id attribute is ‘’

It looks like a problem with your Android app setup and not Backendless APIs. Have you tried posting it to an Android discussion group/support forum?