Support Topics Documentation Slack YouTube Blog

No response on Backendless.sharedInstance().file.listing request


(Active Solution) #1

My IOS app became to get no response from the “Backendless.sharedInstance().file.listing” service. It does not calls any callback, or does not returns from the synchronous call, just pushes errors -1001 and -999 to the console periodically.
Equal REST request works ok. Did try to download and build the project template. It has same issues (-1001, -999) with the “Backendless.sharedInstance().data.ofTable” service as well. Did try to update framework versions 4.0.20 -> 4.0.29 -> 5.2.13, still no luck. This application had been published about a half of a year ago, and had not any problem with the Backendless services. Nowadays build except that the XCode updated to the latest version, has some changes: due to the original dev account is temporary not active, the app has been built under differ dev account and bundle id. Does it matter? Looks like the Backendless does not use this info, at least at the new app registration. Any advice?

Details:

Client SDK: Swift

Application ID: DC7022A2-9763-0926-FFE9-FCDB65A3B900

Expected Behavior

Please describe the expected behavior of the issue, starting from the first action.

  1. Calling Backendless.sharedInstance().file.listing(…) service.
  2. Retrieving a list of files or error by proper handler calling

Actual Behavior

  1. Calling Backendless.sharedInstance().file.listing(…) service.
  2. Retrieving nothing (no return from the service), only messages repeatedly appearing in debug console:
    2019-06-05 12:18:06.896074+0300 Atarius Sound[2289:321518] Task <68BA20E1-6C12-4E63-A8AE-C971E10854E7>.<1> finished with error - code: -1001

2019-06-05 12:18:06.914276+0300 Atarius Sound[2289:321518] Task <68BA20E1-6C12-4E63-A8AE-C971E10854E7>.<1> HTTP load failed (error code: -999 [1:89])

2019-06-05 12:19:08.833454+0300 Atarius Sound[2289:321518] Task <313079A1-56B0-4CF8-95B2-BBB1842FA8CF>.<2> finished with error - code: -1001

2019-06-05 12:19:08.836896+0300 Atarius Sound[2289:321518] Task <313079A1-56B0-4CF8-95B2-BBB1842FA8CF>.<2> HTTP load failed (error code: -999 [1:89])

Reproducible Test Case

You could take look at the “project template”, downloaded from the application page. It’s reaction to the “Backendless.sharedInstance().data.ofTable” request looks same, except that it calling callback with the 1001 error, while the application looks lite tries to retry request instead to return error (50+ times at the moment)


(Olha Danylova) #2

Weird. Could you please create a simple code sample that reproduces this issue because we cannot reproduce it. I’ve connected to your app and requests work fine (e.g. I can retrieve all SerialNumber objects)
You can attach your project’s link here or send to support@backendless.com

Regards,
Olga


(Active Solution) #3

There is the simple code sample, which tries to run query, which REST equivalent works fine: https://api.backendless.com/DC7022A2-9763-0926-FFE9-FCDB65A3B900/33E5BFE7-2FDA-A6C8-FF04-3A39470B9A00/files/Test%20ASU%20Firmware

It retrieves these messages in console, and a 1001 error after the timeout ens:

2019-06-05 15:57:51.668391+0300 BackendlessIssueSample[2432:346005] Task <96F700BB-BA33-4CDF-B231-CD85139A71CF>.<1> finished with error - code: -1001

2019-06-05 15:57:51.685850+0300 BackendlessIssueSample[2432:346093] Task <96F700BB-BA33-4CDF-B231-CD85139A71CF>.<1> HTTP load failed (error code: -999 [1:89])

P.S.: The project archive will be sent to the email, because “Sorry, new users can not upload attachments.”


(Olha Danylova) #4

I’ve downloaded your app, installed Backendless (5.2.13) and that’s what I’ve got (without any additional actions):

Regards,
Olha


(Active Solution) #5

I’ve got the same result on simulator (did not try on simulator brfore).
But on a real device I’m getting timeout error, did try to add “AllowsArbitraryLoads” to the plist, but still no success.

Could you check on real device, please? Possible something wrong with the lib for the arm* architecture08


(Olha Danylova) #6

Works on the real device too (iOS 12.3.1)

IMG_1928

Maybe you have the wifi proxy configuration on your device?

Regards,
Olha


(Active Solution) #7

Yes, thanks a lot! Got success with the cellular connection, the problem was with wifi provider. Sorry, hadn’t any issues with this wifi before… solved