Support Topics Documentation Slack YouTube Blog

No such module 'Backlendless'

Hey,
I use to use backendless years ago, and I’m back trying to get it running again. I have run into an issue which the google doesn’t have allot of information on. All I want to do is see how things are done now in a simple CRUD / Project template so I can get on with my day. However, I have experienced an odd behaviour that I haven’t even been able to find an answer for.

I did read someone this isn’t an issue with backendless but more so XCode, As anyone experienced the below and have a solution they could point me in the right direction to fixing it? It is occurring in both Swift and Objective C…I have tried both.

Backendless Version (3.x / 5.x, Online / Managed / Pro )

Online Latest Version

Client SDK (REST / Android / Objective-C / Swift / JS )

Swift / Objective C
XCode (Latest Version 12.4)

Application ID

com.acme.com

Expected Behavior

Please describe the expected behavior of the issue, starting from the first action.

  1. created a table in backendless - very simple
  2. download project template - to see how the code is compiled and used.
  3. Installed Pods
  4. Updated Pods
  5. Open’d XCode - built project

Actual Behavior

  1. created a table in backlendless - success (tested with internal tools
  2. downloaded project template
  3. Installed pods
  4. Updated pods - just in case.
  5. Connected project to Apple Platform (i.e. connected the developer certificate)
  6. Build Project
  7. Failed - (Swift Compile Error - No such module ‘Backlendless’)
  8. Uninstalled XCode - ( one possible solution found on the internet)
  9. Repeated steps 1-7
  10. Failed again
  11. Swear at computer send this message.

Reproducible Test Case

Honestly just download from the administration from backendless.

Hi Jeremy,

Welcome to the community. You’re right, it should be as simple as you have described, that’s exactly what I’d expect as well. My xcode is rather old (10.1), my experience would not be representative, but we will definitely figure out the problem.

@olhadanylova, any ideas why the project template doesn’t work out of the box?

Regards,
Mark

1 Like

Thanks Mark,

It may be POD issue but i’m simply not sure how its put together. Thanks in advance!!

Cheers,
Jeremy

Hello @Jeremy_Watson,

I’ve tried with Xcode 12.4 and everything builds fine. Could you please provide a simple project that reproduces this issue?

Regards,
Olha

Hi Olha,
Thanks for responding. I simply generated it from the Administration of the Backendless. Attached is the file. I have done this in Swift and Objective C. If I can figure out what I have done wrong then I can fix the other ones as well.

GroundTheory.zip (448.1 KB)

Cheers,
Jeremy

Hi @Jeremy_Watson

This error may occur if you open xcodeproj file instead of xcworkspace. Try following these steps:

  1. Download project template and unzip it.
  2. Run pod update inside project folder. The .xcworkspace file will be generated.
  3. Launch XCode, choose Open Project or File and select xcworkspace file.

These instructions worked fine for me.

Best Regards,
Maksym

1 Like

Hi Maksym,

That got it working. How very odd as I did try that once before, clearly I had something wrong. Thank you I’ll mark it as correct.

Cheers!
Jeremy