Support Topics Documentation Slack YouTube Blog

ObjectID always null when using MapTableToType


(Kris Portier) #1

Hello,

I’m a bit a new user of backendless so it’s possible that I ask a stupid question. I’m currently using .NET is a client and I’m using MapTableToType to fillup my own classes.

I’ve created a property objectID to retieve te unique key. Too my surprise the property isn’t filled. I’ve tried change the case of the property to all kinds. But nothing helps. Is it possible that this feature isn’t working or am I doing it wrong?

Please a bit of advise because I’m searching for a solution for this for hours and I just want de fetch a list of object and make it possible in my app to change and update the data. WIthout the objectID everytime an new object is created.


(Mark Piller) #2

Hi Kris,

Try changing the property to “objectId” and let us know if it works.

Regards,
Mark


(Kris Portier) #3

Hello Mark,

That solved my problem. Thanks for the quick solution.

One remark, When you use the business logic and choose to download the service SDK. The generated property is objectID. That’s probably a bug then.

Regards,

Kris


(Mark Piller) #4

Thanks for letting us know, Kris. I opened an internal ticket to correct this.

Regards,
Mark