Support Topics Documentation Slack YouTube Blog

OnUploadSuccess logic gone

Hi
I’ve implemented a lot of block logic in UI Builder for the event OnUploadSuccess of a File Upload Button.
When opening this in UI Builder, I saw the logic has disappered and replaced by the blocks I have in the Target Directory Logic. Also, the CHANGLOG is showing no meaningful history

Can someone please restore the logic for the OnUploadSucces which I had one or two days ago? Or even later back in time - this was a stable logic.

AppID: 5BDF0E64-9F03-6F8E-FF75-0E183AF61100
page: recipes-detail
FIle Upload Button ID: fileUploaderButton-2-2-2-2-2-2

Regards,

Hello @Klaas_Klever

We have backups of your application for 20/05 and 25/05

We can restore the app from a backup. There is an administrative fee of $200 for us to do that. The fee covers the time of our team working on the restore process. Let me know if you would like to proceed.

Regards,
Inna

Hi @Inna_Shkolnaya ,
As mentioned above:

" When opening this in UI Builder, I saw the logic has disappered and replaced by the blocks I have in the Target Directory Logic. Also, the CHANGLOG is showing no meaningful history"

It’s not my fault that this logic has disappeared. Cannot accept to pay for the backup restore.
Restoring the whole app from backup will not help me anyways, because this will undo other changes I did.

I apologize for the misunderstanding. We are investigating this problem.

Thank you!

Hi @Inna_Shkolnaya ,
Any update on this?
Regards,

Hello @Klaas_Klever

Sorry for the delay, we’ve restored the logic for the OnUploadSucces handler to the state of 25/05/2021.
Could you please confirm if it works for you?

Regards, Vlad

Hello @vladimir-upirov ,
Logic is back and is working again.
I’m wondering why the logic could have been lost. I had some similar experiences with UI BUilder in the past, which I could correct using the CHANGELOG history fo the block logic screen. I’m often using multiple tabs in chrome when working with UI Builder. Are there known issues when working with multiple tabs?

Thanks,

Yes, it could be the reason. You see, when you use more than one tab (for UI-Builder) the UI and logic can be desynchronized and you can experience such behaviour.