Oops..problem unlocking springboard

I just finished all the missions to unlock the springboard but somehow I did something wrong and got charged $50 for it when I was trying to change from the trial plan to the springboard. Can you assist to sort this out? I had put my credit card in previously and couldn’t delete it since it isn’t needed in this demo version. Sorry!

I suppose I could use the points on my other production app I will create in the future if I can apply them towards it. I just don’t know how that works.

What is the application ID where you got a $50 charge?


Hi Mark, it is:


Hello, now that I have switched I am also getting the message below as I try to test. I guess I should have just stayed on the trial for the 11 more days so I could finish building out everything…

{“code”:9070,“message”:“The API request has been rejected because it requires scaling for processing. Switch to the Cloud9 or Cloud99 plan to enable the Super Scaling option.”,“errorData”:{}}


NM…I think I figured this out.

Hello @Ryan_Belisle,

Glad you’ve figured it out.
Please let us know if you have any further questions.


Well, I mean I figured out the other problem that I deleted but I still have the problem where I got the $50 charge even though I completed all the missions. Can you help resolve that?

@Ryan_Belisle ,

I see in the transactions log that you have bought “Springboard” shortcut.
I have several questions:

  1. When you have unlocked Springboard? I am interested in exact date and approximate time.
  2. What were your actions after unlocking free Springboard?

Regards, Andriy

Hi Andriy,

The date I unlocked this was right before I opened this thread…a few minutes before I got charged. The only thing I can think is that I had put in my credit card into the system earlier during the demo because I thought it was needed. It would not let me remove it from the file, even though I tried to avoid any accidental charges. (can you remove it?) When I unlocked the free upgrade, it still didn’t show as available and was greyed out when I went to the billing section to change the subscription. So, I thought maybe I had to go to the store to “buy” it for free. When I went to the store the graphic had an unlock icon and said $0 so naturally I thought to click it to buy. It didn’t give any other “are you sure” message to confirm the price it just did its thing and charged me $50. It obviously didn’t recognize I had already unlocked it. At that point I was able to switch in the billing section to the springboard plan after the “purchase” had gone through.

Unfortunately, I later found out that it was giving me an error 9070 with the new plan as stated above.

Hi @Ryan_Belisle ,

I have checked our logs and I see that you unlocked free Springboard but didn’t assign it to any of your apps. I will remove purchase of “Springoard” from your app, move it again to the Cloud 99 with trial till 12th of December and process refund for that purchase. Money will be returned on card during 5 working days.
To assign your free Springboard to that app you should go to “Missions” section. There system should ask you to assign free Springboard to one of your applications.

So, I thought maybe I had to go to the store to “buy” it for free. When I went to the store the graphic had an unlock icon and said $0 so naturally I thought to click it to buy.

This is really strange case. We checked it and were unable to reproduce behavior which you have described. There was correct price for the product and also confirmation before purchase.

Regards, Andriy

I messed something up in the files trying to bring it down under the limit for the cloud 9 plan and now it says an error. I must have deleted too much. I tried to restore from a backup but I still have it saying this. Can I restore the backup?

Application ID: 81CB0A51-99CD-A816-FF40-D7DECA745800

Can't find service scheme. Please, try redeploy you service.

@Ryan_Belisle ,

Could you please create a separate topic for this problem?
Your current problem is not related to the billing problem.

Regards, Andriy