Oracle 12c Data Connector Issues

I am having issues getting the Oracle Data Connector working on the Backendless Pro platform. I have tried both versions 11g and 12c, but I am still getting an “ORA-01017: invalid username/password; logon denied” error.

I have already hopped on a call with our inventory system vendor’s database admin, and he is unable to find a reason for the error. I have tried 4 different sets of login credentials, all of which should work since they are actively being used on quite a few ODBC connections, and I tested them all in Oracle SQL developer to verify. Any thoughts on the possible cause of this issue?

Hello @Tyler_Johnson

If you’re facing challenges with the standard connection options in Oracle and the simplified form like the following:

Consider utilizing the JDBC url for a more flexible and customized connection.

Oracle offers an extensive range of connection parameters, and using the JDBC string allows you to fine-tune your connection settings to better suit your specific needs. This approach provides greater control and adaptability in configuring your Oracle database connection.

1 Like

Hi Sergii,

Thanks, that got me further than I was, but now I am getting a new error. I’m wondering if it might be due to the bt-rt-server being stuck at Changing on the Pro Manager? I have tried stopping and restarting the process, but it doesn’t seem to progress. I included the log for that process.

bt-rt-server.log (32.6 KB)

hello @Tyler_Johnson

I wanted to address the issue with bl-rt-server. It’s important to note that this problem doesn’t impact the Database connection. To resolve it, kindly access Consul using the following address: http://<machine-ip-or-localhost>:32600/ui/#/dc1/kv/config/rt-server/. Once there, add a new key managementHttpPort with the value 2992, and then restart bl-rt-server.

Regarding the error you encountered, Unable to connect to Backendless Server (ECONNRESET) it seems to be related to bl-server, even though the provided screen suggests everything is in order. Please try reloading the Backendless console in your browser and attempting the operation again. If the issue persists, consider restarting bl-server. Should this not resolve the problem, please share the logs from bl-server by attaching them to this topic.

Your cooperation is greatly appreciated.

Best regards,

1 Like

Hi Sergii,

Both of your recommendations worked. bl-rt-server is now running and I am able to see our database through the Oracle Data Connector. Thanks for all your help.