Support Topics Documentation Slack YouTube Blog

Outage with business logic timers

Backendless Version (3.x / 5.x, Online / Managed / Pro )

6.0.6

Client SDK (REST / Android / Objective-C / Swift / JS )

6.0.1.1

Application ID

130CA81A-36A3-9479-FFEE-AB623F4D0E00

Expected Behavior

Timers execute as per schedule

Actual Behavior

No timers execute unless manually triggered. Same for production or codeRunner

Hi @mitchell,

for how long do you observe this behavior? When it started?
How do you know that timers won’t run (how do you check it)?

Stanislaw

Hi @stanislaw.grin,

Each time the timer runs it should add an entry to a table. One way I can tell is there should be an entry added every ~60 seconds. See screenshot of when it stopped. The most recent two entries are manually run.

I also am watching the real time log under Management -> Log Management -> Real-time logging
Each time a timer runs it has output in the log. I am only seeing log entries when I manually run the timers

I am also experiencing issues receiving push notifications to iOS. The timer that sends the notifications completes execution (when run manually), but no notification is received on my end.

This timer code has not changed and has been working previously for several months.

Thanks for info @mitchell, we’ll take a look into it.
For the first issue with timers I have created internal ticket which you can reference by its ID - BKNDLSS-22397.

For the second issue with notification, I will contact with our iOS developer and we’ll see what goes wrong there…

Regards,
Stanislaw

Thanks very much @stanislaw.grin

Just found this as well, clicking on the ‘show execution history’ of one of the timers.

Have you tried to change “start date” of your timers to more recent date?
Here is what I see when opening execution history of javaWorker timer

Yeah I just tried updating the start date to a few days ago, hasn’t seemed to make a difference yet…

But you can see there on your end how the timer stopped running every 60 seconds like it should

Yeah, I see that it stopped on 08/06/2020, will investigate this.
Regarding ‘Invalid Date’ - this bug is appear if you use Safari browser, we’ll fix it also, but if you open this window using Chrome, you’ll see correct dates.

Ah yep that was it. I was using Safari. All good on Chrome. Thanks :slight_smile:

Hello @mitchell we have the issue with timers

Hey @sergey.kuk, thanks for the update. Any idea when the issue will be resolved? And any word on push notification outage?

sorry @mitchell, I have typo in the message. I wanted to say that we fixed the issue with timer.

Oh great. Thanks for getting it fixed quickly, I appreciate it. I have just tested and push notifications seem to also be resolved.

many thanks

You are welcome, sorry for outage.