Overflow in CSS shows in UI Builder but not on desktop preview

Hi

Selecting overflow and setting it to hidden on the row component in UI builder does not truncate long text in the text component within the row. I provided a class in the text component inside a row and defined the style in an extension as:

.rowoverflow {
white-space: nowrap;
overflow: hidden;
text-overflow: ellipsis;
}

As a basic example I get the following in UI builder:

But when I run it in Destkop preview or on my phone I get:
Preview overflow

So two questions:

  1. is the text overflow option (against a row) in UI Builder not working?
  2. If I get around it using a style change in an extension am I doing something wrong where the effect is shown in UI Builder but not the desktop preview or phone preview?

Thanks

Hello @Glenn_D

Could you provide a page name where I can see this behavior?

Regards, Dima.

Hi @Dima_Vak

Thanks for replying.

The configuration I have setup for the demo is below. You can see the cell has the overflow property set to hidden. But the cell still has multi line displayed.

To remove the multiline. The following pictures show setting CSS class to rowoverflow and then the rowoverflow CSS extension, which displays only one line.

I have published the app with the extension and the overflow attribute for the cell set to hidden. But the app still shows multiline even though in UIBuilder it truncated the cell to only show one line.

Note placing the rowoverflow CSS in the text element instead of the cell element shows the ellipses and looks better, but, I put it in the cell element to keep it consistent with what seems to be not working when you set overflow → hidden attribute on the cell.

@Glenn_D

Could you add important to white-space?

white-space: nowrap !important;

Hi @Dima_Vak

Thanks for the reply. Putting !important on white-space overrode the white-space break-space default style for a text element and gave me the result I was looking for in the app view. That will remind me to look at the code.

Much appreciated.