Phantom object in CBL

Hello! I have a problem with retrieve data from tables. I wrote request in CBL where get specific data from table with a few relations. This relations loading using two step retrieval method. When all data received and list ready to send to client application, I debug it and check that all relations loaded and this is correct data - all fine and correct. After this in API Inspector I got almost same result except last item, which doesn’t contains any relations. I try to find this object by objectId but in table no such object with this ID. What it can be? Maybe I’m made mistake somewhere?
Abstact code snippet:

BackendlessDataQuery query = new BackendlessDataQuery();
query.setWhereClause("ownerId = '" + userId + "'");
List<String> relations = new ArrayList<String>();
BackendlessCollection<SomeTable> collection = Backendless.Data.of(SomeTable.class).find(query);
List<SomeTable> result = collection.getPage(10, 0).getData();
for (SomeTable item : result) {
 Backendless.Data.of(SomeTable.class).loadRelations(item, relations);
return result;

Thanks in advance!
Btw I’m using latest CodeRunner for Java(3.0.17)

Hi Oleh,

What is your application ID? Can we use your handler in order to reproduce the problem?

Hi Sergey,
Sorry but I tried to find some solutions for this and I already changed code. I used single step retrieval and now it works. Server returned data which I needed. There are some big difference of using single step retrieval and two step retrieval? Which approach better or faster?