Support Topics Documentation Slack YouTube Blog

Problem resulting from cloning an app

This happened when I cloned this application from another application. Looking at the console I have an error message warning beside the table ‘Voucher’. I don’t need this table anyway so I tried to delete it, but this gave another error message. I tried cloning again in case a once off, but the same thing happened again. If you could remove the voucher table for me or get it fixed up so that I can delete it please and check everything else is ok on this app please before I continue development with this app Id. Thanks, Mike

Application ID: 62F94B85-91B6-46F3-857F-8EE69A16717B
Error UID: ED89452E-AABD-915F-FFA1-43CDF98AF100

Backendless encountered an error while handling the request. An internal trouble ticket with ID ED89452E-AABD-915F-FFA1-43CDF98AF100 has been created and we will be investigating the issue.
java.sql.SQLSyntaxErrorException: Unknown table '62F94B85-91B6-46F3-857F-8EE69A16717B.udt.Voucher'
java.lang.RuntimeException: java.sql.SQLSyntaxErrorException: Unknown table '62F94B85-91B6-46F3-857F-8EE69A16717B.udt.Voucher'
	at com.backendless.services.persistence.schema.DatabaseOperation.handleDdlException(DatabaseOperation.java:185)
	at com.backendless.services.persistence.schema.DatabaseOperation.lambda$doExecute$2(DatabaseOperation.java:162)
	at com.backendless.datamodel.dao.JpaTransaction.executeSync(JpaTransaction.java:273)
	at com.backendless.datamodel.dao.JpaTransaction.executeAppSync(JpaTransaction.java:183)
	at com.backendless.datamodel.dao.JpaTransaction.lambda$executeApp$1(JpaTransaction.java:210)
	at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1700)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
	Suppressed: java.util.concurrent.ExecutionException: java.lang.RuntimeException: java.sql.SQLSyntaxErrorException: Unknown table '62F94B85-91B6-46F3-857F-8EE69A16717B.udt.Voucher'
		at java.base/java.util.concurrent.CompletableFuture.reportGet(CompletableFuture.java:395)
		at java.base/java.util.concurrent.CompletableFuture.get(CompletableFuture.java:1999)
		at com.backendless.async.UncheckedCompletableFutureImpl.getUnchecked(UncheckedCompletableFutureImpl.java:158)
		at com.backendless.services.persistence.schema.DatabaseOperation.doExecute(DatabaseOperation.java:169)
		at com.backendless.services.persistence.schema.DatabaseOperation.lambda$execute$0(DatabaseOperation.java:123)
		at com.backendless.util.sync.RedisSync.execute(RedisSync.java:107)
		at com.backendless.util.SyncUtil.execute(SyncUtil.java:45)
		at com.backendless.util.sync.ISync.execute(ISync.java:33)
		at com.backendless.services.persistence.schema.DatabaseOperation.execute(DatabaseOperation.java:126)
		at com.backendless.services.persistence.common.TablesService.removeTableByName(TablesService.java:244)
		at com.backendless.management.persistence.DirectManagementService.lambda$deleteTable$1(DirectManagementService.java:296)
		at java.base/java.util.Optional.ifPresent(Optional.java:183)
		at com.backendless.management.persistence.DirectManagementService.deleteTable(DirectManagementService.java:287)
		at com.backendless.management.persistence.DirectManagementService$$EnhancerByGuice$$b0222dd.CGLIB$deleteTable$7(<generated>)
		at com.backendless.management.persistence.DirectManagementService$$EnhancerByGuice$$b0222dd$$FastClassByGuice$$52fd21ff.invoke(<generated>)
		at com.google.inject.internal.cglib.proxy.$MethodProxy.invokeSuper(MethodProxy.java:228)
		at com.google.inject.internal.InterceptorStackCallback$InterceptedMethodInvocation.proceed(InterceptorStackCallback.java:76)
		at org.jsr107.ri.annotations.guice.CacheRemoveEntryInterceptor.proceed(CacheRemoveEntryInterceptor.java:56)
		at org.jsr107.ri.annotations.guice.CacheRemoveEntryInterceptor.proceed(CacheRemoveEntryInterceptor.java:31)
		at org.jsr107.ri.annotations.AbstractCacheRemoveEntryInterceptor.cacheRemoveEntry(AbstractCacheRemoveEntryInterceptor.java:63)
		at org.jsr107.ri.annotations.guice.CacheRemoveEntryInterceptor.invoke(CacheRemoveEntryInterceptor.java:51)
		at com.google.inject.internal.InterceptorStackCallback$InterceptedMethodInvocation.proceed(InterceptorStackCallback.java:78)
		at com.google.inject.internal.InterceptorStackCallback.intercept(InterceptorStackCallback.java:54)
		at com.backendless.management.persistence.DirectManagementService$$EnhancerByGuice$$b0222dd.deleteTable(<generated>)
		at com.backendless.management.persistence.DataManagementService.deleteTable(DataManagementService.java:112)
		at controllers.console.DataManagement.lambda$deleteTable$6(DataManagement.java:189)
		at com.backendless.async.ExecutorService.lambda$submit$0(ExecutorService.java:67)
		... 4 more
Caused by: java.sql.SQLSyntaxErrorException: Unknown table '62F94B85-91B6-46F3-857F-8EE69A16717B.udt.Voucher'
	at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:120)
	at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:97)
	at com.mysql.cj.jdbc.exceptions.SQLExceptionsMapping.translateException(SQLExceptionsMapping.java:122)
	at com.mysql.cj.jdbc.ClientPreparedStatement.executeInternal(ClientPreparedStatement.java:953)
	at com.mysql.cj.jdbc.ClientPreparedStatement.executeUpdateInternal(ClientPreparedStatement.java:1092)
	at com.mysql.cj.jdbc.ClientPreparedStatement.executeUpdateInternal(ClientPreparedStatement.java:1040)
	at com.mysql.cj.jdbc.ClientPreparedStatement.executeLargeUpdate(ClientPreparedStatement.java:1347)
	at com.mysql.cj.jdbc.ClientPreparedStatement.executeUpdate(ClientPreparedStatement.java:1025)
	at org.apache.commons.dbcp2.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:136)
	at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.executeUpdate(ResultSetReturnImpl.java:197)
	at org.hibernate.engine.query.spi.NativeSQLQueryPlan.performExecuteUpdate(NativeSQLQueryPlan.java:107)
	at org.hibernate.internal.SessionImpl.executeNativeUpdate(SessionImpl.java:1507)
	at org.hibernate.query.internal.NativeQueryImpl.doExecuteUpdate(NativeQueryImpl.java:295)
	at org.hibernate.query.internal.AbstractProducedQuery.executeUpdate(AbstractProducedQuery.java:1612)
	at com.backendless.services.persistence.schema.DatabaseOperation.lambda$doExecute$1(DatabaseOperation.java:146)
	at java.base/java.util.ArrayList.forEach(ArrayList.java:1541)
	at com.backendless.services.persistence.schema.DatabaseOperation.lambda$doExecute$2(DatabaseOperation.java:144)
	... 7 more

Problem description

Describe what you did in console that led to the error. Please provide a description of what actually happens. Be descriptive: “it doesn’t work” does not describe what the behavior actually is. This will help us with reproducing the problem.

Steps to reproduce

Please describe steps to reproduce starting from the first action.

Hi @mike-turner !

Sorry for inconvenience. I have deleted table ‘Voucher’ from your app. Everything seems to be OK with this app.
Could you please check and confirm that problem is gone?

Regards, Andriy

Yes thanks that seems to be ok now.

However noticed another problem related to me cloning the app. The App I cloned (7EFD57D0-0366-41B6-9841-FAA1360ED5EE) now seems to be acting weird in the console. If I view the Users on the users table the console becomes unresponsive. I can’t click on anything after I look at the Users table and have to close the browser window. I have tried this 4 times now and exactly the same thing happens. Doesn’t happen on any of my other backendless apps, just this one. A bit strange?

Mike

Yes, it is a weird behavior.

I have created an internal ticket BKNDLSS-24543 for this problem. We will notify you when fix will be released.

Regards, Andriy

Hi Mike,

can we make a clone of your app in order to investigate this issue?

Stanislaw

Yes no problem

Hi Mike,

there is some weird issue just with Chrome. We will look into this more in depth.
Firefox shouldn’t have the same problem, so you can try this browser for console or just data tables. I know this is a frustrating issue and we will try hard to find a way to fix it for Chrome.

Regards,
Stanislaw

Hi Stanislaw

Thanks for the update, Is it somehow linked to me cloning this app? I don’t have this issue with other apps on Chrome which is why I ask. Just this one. I don’t know if it was showing this behaviour before I cloned to be honest , but it seems to be a coincidence.

Just tried on Safari on mac and confirm that is behaving normally.

Mike

It shouldn’t be linked to your app, this issue is noticeable when there is a lot of column in the table (like in your cloned app)

Stanislaw

ah ok, but I also have same columns in other apps. It doesn’t matter, I just thought it might be linked in some weird way I don’t understand thats all.