Progress Lost - No Changelog button is available

App ID: 4A47197B-AE30-FA84-FF56-0071F4010900

Link: /services/BG_17_CHARGEBEE_UPDATE/DEV_Create_Chargebee_Placeholder_By_LeadId

Method name: DEV_Create_Chargebee_Placeholder_By_LeadID

Hello, our developers just reported that their code is not saved and they get an error message:
The specified resource was not found.

Can you investigate?

What is the name of the deployment model?
What other services/timers/event handlers exist in the same model?
How many people on the team work on business logic?


Hi Mark -
the name of the deployment model BG_17_CHARGEBEE_UPDATE
3 people are currently working on various methods.

see screenshot regarding the other services.
Screenshot 2022-06-20 at 6.06.09 PM

When you deploy a service, what is deployed is not just the method you worked on or the service that contains the method, but the entire deployment model. There is a popup shown by Backendless Console that informs about.

If three people work on different methods of the same API services, and one of them deploys the changes, it will ignore and actually invalidates the changes in the same deployment model done by others.

Is this what you think is going on in your app?

We are aware of this, but we are not working on the same deployment model. We are working on backendless in general on methods of different deployment models.

So this is not what is going on in our app.

Can you please investigate the logs?
We don’t even have the changelog button to check what is going on.

@mark-piller I am not sure what is going on, but the code just appeared to the method and it seems it is OK.

That’s odd, we haven’t done anything (yet). Were there any connectivity issues on your end?

@mark-piller - We have no connectivity issues. The developer who’s working on the project is working remotely today and I tried accessing the method from my end as well and got the same error message.