Support Topics Documentation Slack YouTube Blog

Push Certificate Mode does not change when installing Production certificate


(Jonathan ) #1

I deleted my Sandbox certificate and when I uploaded a production certificate and selected “Production” and hit “Save”, it still says “Sandbox” in the Certificate Mode column. When I go to edit this certificate to select Production, it says Key or Certificate for channel already exists.

Not sure what’s going on here but I’d like to be able to switch between Sandbox and Production.


(Vladimir Upirov) #2

Hi Jonathan
Thank you for your report, and could you please provide your appId and we will try to figure out what’s going on there
Regards, Vlad


(Vladimir Upirov) #3

An internal ticket for investigation the issue has been created, the ticket number for reference is BKNDLSS-18423


(Jonathan ) #4

Hi @vladimir-upirov is there any progress or update on this issue?


(Vladimir Yalovy) #5

Hello @Jonathan1

Not yet. We are working on this task. As soon as there will be some news, we will inform in this topic.


(Jonathan ) #6

@Vladimir_Yalovy so will push notifications not work for me until then?


(Oleg Vyalyh) #7

Hi, Jonathan. We are working on it.

Also pay attention that now Backendless automatically determine what certificate you are uploading (you should generate appropriate certificate on the Apple site).
As a workaround i would recommend delete the certificate and upload the new one that was generated as “production”.


(Jonathan ) #8

I had re-uploaded the Sandbox certificate earlier because I was trying to get the Sandbox certificate working again but that didn’t work either. SO I have uploaded the production certificate again. can you please check it? It is still showing as Sandbox. I have also run an openssl check to make sure it says Production Push Services before uploading


(Jonathan ) #9

Hi @oleg-vyalyh any updates on this issue? Thanks


(Olha Danylova) #10

Hello Jonathan,

Ticket is still in progress. We will report here when it is done.

Regards,
Olha


(Jonathan ) #11

Is there any updates here? I can’t send push notifications on production now and I don’t understand why.


(Mark Piller) #12

Hi @Jonathan1,

What certificate do you have now uploaded to Backendless?
What mode is it configured in our console?
How do you run your app? In a simulator or installed from the appstore?

Regards,
Mark


(Anton Govorushkin) #13

Hi @Jonathan1

We’ve just released an update. Everything should work fine now. Please verify

Anton


(Jonathan ) #14

I think things are working with this update. I cannot fully test because it seems like something on the server is causing my business logic code to timeout and fail.