Push certificate - password length/character limit?

Context: https://backendless.com/documentation/messaging/ios/messaging_push_notification_setup_ios.htm
Sorry if you see the same question on Disqus where I entered one but it didn’t seem to persist.
After generating a new cert, exporting it with a password in a format “word.word.word.word.word.word.word” and uploading the .p12 + password (copy/paste). I get an “Internal server error with id …” (see attached image).
How can I debug this? Is there a character length limit on backendless side?

Screen Shot 2016-03-10 at 4.01.20 PM.png

I just tried a shorter password and the save worked.
What’s the ‘certificate password’ character limit in backendless? Could you add that hint in the UI ?

The maximum length of the password is 45 bytes. Have you exceeded this limit?

Looks like I have indeed, thanks for the heads up. Would appreciate an error messaging ( Exceeded max password length of ## chars) or UI text (max ## chars) to avoid confusion :slight_smile:


Yes sure, we’ll now handle this error properly. Thanks for accidental testing :slight_smile: