Push notification iOS not send or received

App ID = 28A40095-0806-3BDD-FFC1-FED764753200

I am trying to send a push notification from my server code timer to my iOS device (Android is working great). The iOS device is successfully registered in the Messaging tab under devices. The p12 certificate I uploaded is working with an external test tool called houston, it can successfully send a push notification to my device with it. Sending manually from the web console also does not work, but that also doesn’t work on Android.

Any ideas what might be causing this?


to diagnose a problem:

  1. send a push notification, as a response you will receive message status, which contains
  2. in a minutes call “get message status” api https://backendless.com/docs/rest/doc.html#messaging_get_message_status_2 :
  curl https://api.backendless.com/<application-id>/&lt;REST-api-key&gt;/messaging/&lt;hole-messageId-value-from-message-status-response&gt;

Here’s the output of the response:
{ errorMessage: null, messageId: ‘message:0D8157A1-7257-3748-FFFF-7B884810F800’, status: ‘scheduled’ }
The REST request returned:{“errorMessage”:null,“messageId”:“message:0D8157A1-7257-3748-FFFF-7B884810F800”,“status”:“published”}

Push did arrive on Android, not on iOS

I was wondering, is this enough information for you to backtrack what happened? Or do you need me to try something else?

Hi Maarten,

Which type of certificate do you use for iOS push? I heard there are development/sandbox and production certificates.

It’s a Apple Push Services production certificate

Have you tried to send a push with a development certificate instead?

I just did and it worked!

How to proceed?

Thanks for getting me on the right track. Somewhere down the road things started working and I forgot to test with a production build.

So, can I mark this topic as resolved now?

yes and thanks for the great support as always