Rest api returns 302 Found

I am trying to register an user on
I am able to register by using Rest Console, but I got 302 Found error when I try to register from the application. I tried with, but I got same result. I granted all permissions on all user types… but no change. What I did wrong?

Is your application Android, iOS, JS, .NET, Flutter?
Do you use an SDK?

Thank you, for the fast answer.

I am using Android with Retrofit2 library for the network calls.

Just to confirm, you are not using our Android SDK?

Yes, I do not use the SDK for Android. Trying to register with POST request.

What does the request body look like?
What http headers do you set?

{email: “test@test.te”, name: “test”, password: “123123”}

this is agains rest console

I found some strange message in the logs:
{“code”:3048,“message”:“Session timeout. Url:”,“errorData”:{}}

Is your app in the EU data center?

How to check? I am from EU but not sure how to check.

What flag do you see here?


Could you export the failing request in the curl format and share with me? You can exclude your API key - I will get it directly from the app.

It looks like with curl works :frowning:
It is very strange I will try to see what wrong is with the app.

Should I use android key when the requests are made from Android app but not using the SDK?

The key is used by the backend to identify the client type for analytics purposes. Additionally, you can assign permissions to different keys. If you didn’t assign any permissions, it doesn’t matter what key you use (except for the Cloud Code key - that one must be kept a secret).

Why I am receiving this strange error code 302. It works with curl but I build the same request from app and this code is returned.

I do not know why, I need to be able to reproduce the error to be able to answer the question. I assume there is something wrong with the formatting of the request.

Hmmm I think I found it I send empty token :smiley: in the header.
Sorry, for bothering you. That was the case, I was sending a header “user-token” : “” and thats why I was getting the error.

Thanks for the support