Select component malfunction

RE: Video --Database Integration - Saving data in the database

In the video, at the time of 3:37, the select component shows a dropdown with options 1, 2, 3 when the field is clicked in. When attempting to build the page to replicate this tutorial my select component doesn’t do this, and subsequently when run in Chrome with all logic connected to the field per the video the console states “invalid option item in the Select Component, make sure each option object has defined “undefined” property, otherwise the option will be skipped.” What could be the problem? Tried another select component but same result.

Hi, @Lon_Dailey

Have you figured out what the issue was? It’s most likely about the logic itself, please check if everything is done as Mark shows in the video example. I didn’t have any issues with the logic from the video. Please check the logic and if you didn’t find the issue by yourself, point out the page with the logic.


Hi Marina,

Thanks for the quick response. Your support (Backendless) is a key reason why I’m using the product over competitors, such as Appgyver.

However, I’m at loss as to how to understand the use of a component, such as “select”. Documentation would be very helpful, but I know you must have other priorities.

I created a blank page and dropped in the select component. I expected that it would behave as shown in the video where Mark clicks in the UI and the options drop down. But, this isn’t what happens, so not knowing what to expect makes it difficult to troubleshoot. Again, documentation would help and also lighten the load of support specialists like yourself.

I went through the logic and everything matches what I see in the video. But, the value logic for the select button in the video is empty in the video at 10:47. I suspect the values are coming from the options, but again I don’t understand this component. I changed the value logic in the Select component to “name" and was able to display the drop-down in Chrome and clicked the add address button. But, the Address table while showing the address doesn’t show the neighborhood relation.

My application ID: 78500CF3-F99C-503C-FFB8-C650B1967400

Thanks for your help.

Hello @Lon_Dailey

Select component has two main ideas - value and options.

  1. Options - is a list with objects, which should contain 2 properties.
    Label (words shown at options) and Value (hidden property to describe what data should be applied if we choose this option)
  2. Value - is a string coming from chosen option.

So the reason why you do not have options in the select, may be related to non
existing list with options or keys for options is incorrect.

If this information doesn’t help you, please create a little page where you represent a minimal case that reproduces a problem and provide a page name.

Regards, Dima.