Support Topics Documentation Slack YouTube Blog

Send Emails with Templates API timeout error

Hello,

My SMTP settings (Mailgun) are correct and test successfully. The rest of my custom API method works fine but as soon as it hits the email send, it times out. Nothing is showing up in the logs. I’ve also tried the ‘create list with item’ block instead of the weird little array building (not sure how else arrays can be built in Codeless). My template name is copied/pasted so it’s correct.

Any ideas?

My app ID is B9941993-E38E-A647-FF0F-626E69BF9900.

Hello,

You made it more complicated that it needs to be. This is how you should do it:

I’ve tried that too but it also times out.

I suspect that something before that (relation setting) is causing the timeout so I’ll investigate that. For now, I’ll assume the email sending works.

Your template has a substitution parameter {change_link}, which should get a value when you call the API. This is done using the template values input in the codeless block.

Additionally, I tried sending a test email using this buttong:

The test email message never arrives. It is possible that the SMTP server is blocking or rejecting email.

You might want to login to the email account of ay@jo***con.com to check if there are any bounced messages.

Regards,
Mark