Support Topics Documentation Slack YouTube Blog

Service Method Not Found


(Phil) #1

I’m getting an error with all my calls to my custom hosted services. The error says “service method not found”. I think it may have been because my credit card information was out of date. I updated it but it’s still not working. It also looks like my files in file storage have disappeared. What happened? Please help.


(Mark Piller) #2

Hi Phil,

Could you check if you can invoke the methods using API Inspector? Just to clarify “API Inspector” is this:
http://support.backendless.com/public/attachments/fc9c2eb5b4f5894b89a1da767f06c600.jpg</img>

Regards,
Mark


(Phil) #3

Yes. I can invoke the calls in the api inspector.


(Mark Piller) #4

When you get an error saying the method cannot be found, do you invoke using REST or one of the generated libraries?


(Phil) #5

I download the JavaScript library.


(Mark Piller) #6

Could you please re-download the library and try again? We did an upgrade yesterday and I suspect there is a change in the way the method is invoked (I will schedule a ticket to investigate the backwards compatibility issue, which normally should not happen)


(Phil) #7

Ok. I’ll try tonight. I can’t try right now.


(Phil) #8

I tried again and I’m still getting the error. “Service Method not Found” (400 bad request).


(Mark Piller) #9

Hi Phil,

I was able to duplicate the problem. We will have this fixed asap.

Regards,
Mark


(Phil) #10

Thank you.


(Phil) #11

Any luck on solving this issue?


(Kate Maksimenko) #12

Hi Phil!
Sorry for this inconvenience.

Tomorrow this issue will be solved.

Regards,
Kate.


(Phil) #13

Ok. Thanks for letting me know.


(Kate Maksimenko) #14

Hi Phil!
We already updated service.

Could you try it again?


(Phil) #15

Yes. It works now. Thank you for your help!