.setProperty not working for me in android studio

hello ive been using .setPoperty to update my table and it is not working now
i have attach a screenshot of my code
waiting for your response please

Hi Stephen,

After you do any changes to an object you need to call Backendless.Data.save(modifiedObject) on it to propagate the changes to the backend.

Thanks for you repsonse sergey
its still not making any changes in my database but rather it creates a table and its adding some content i dont understand
what i actually wan to do is when a button is pressed, it should be able to change the property on another users table. Now am able to show some properties from another users properties but i cant make changes to their properties and i have used similar methods to set properties and it worked fine.
i have attach screenshots from my database and my code


Hi stepehen

this docs https://backendless.com/docs/android/doc.html#data_single_object_update should help you

If you want to save a user, then you should pass a user, not its property, to the save() method:

Backendless.Data.save( friendlistone, new AsyncCallback<BackendlessUser> ... );

where “friendlistone” is your variable of type BackendlessUser.

still not working for me. Am sure im not making my intentions clear enough and am sorry for that.
I actually want to change the value of a paticular property called “confirmbymatch” for the user “friendlistone”

Have you studied the doc provided above? It clearly describes how to do an object update, with examples.