Setting relation in object in table causes "validation" error

Created a table with 1:1 relation to another table. When using console, manually opening a record shows everything is fine, “save” button enabled. But as soon as I set a relation to a record in another table, I see a validation error on the (completely unrelated) field below and i cannot save… see screenshot:

The “chosen validator” for the field url is that it’s a string with less than 50 characters… so nothing wrong with the data.

Hi @Alex_Klein

Could you please share your validator?

Ah — I had set it to “URL”. But we actually don’t want this… so I removed the validator, and now relations are possible. Thanks for the hint!

However, another question then: if the validator was set to “URL”, why was the code in our UI builder able to create objects in the table where the data should not have passed the validator? I would imagine that a validator in place would throw an error back when we try to write to the table with data that doesn’t pass, or?

Did the objects created with the logic in UI Builder contain values for the “url” property?

Yes, table was full of records created during testing which all had values in the url column that didn’t match URL format. The codeless block used to write to database was “Save object in Backendless”.

I just tried reproducing the problem. Here are my findings:

Data table schema setup:

UI Builder logic:
UI Builder - ConsoleDemo - Backendless 2023-01-12 15-50-37

Running the logic:

If you find a way that reproduces the issue, please let us know.


Perhaps the regex used in the validator allows format such as “test.test”? That is the format of the strings we were saving, characters with a “.” in the middle.

test.test is a valid value for a URL. The domain is unavailable though :wink:

1 Like

But the console was giving me trouble about the URL field when trying to add a relation to a different field — for us the problem is solved (removed URL validator), but it is curious :thinking: