Styles.less' wasn't found (400) for a new team member

I was creating my app by myself, and now I have sent an invite to work with another person on my app.

When I am logged in everything works fine.
When my teammate logs in there is a “styles.less” error displayed in the Frontend editor:

Hello @Arkadiusz_Kumpin

Can you provide us with your appID? And please don’t share your user token in screenshots.


Hi, my app ID EC1D5D6C-0917-B0A2-FF6A-2D1A0FCAA000

Thank you, I wasn’t aware of what the number was.



Oops, appId is on the screenshot=)
Ok. It tries to get styles from ...files/view/ui-builder... directory. But your app doesn’t have “view” directory. I think it should be ...files/ui-builder.... I don’t know why the styles are trying to get to this path. Let us know if you don’t find out.



thank you a lot for explaining the reason for the error, but I will be grateful if you could share the solution with me :slight_smile: I have tried to look for the styles.less files, but couldn’t find there any way to solve it. Still, it is a bit strange that this error occurs only for one of two users. The current app is a combo of one of the examples from Marketplace, Missions and my simple development (I have used only UI builder). Any suggestions are welcome :slight_smile:


The issue was related to the fact that I haven’t assigned access to the UI Builder to the new team member. After playing around with permissions problem is solved :slight_smile: