Task: Change user status (disable user) Mission not triggering complete

Mission: User Admin
Task: Change user status (disable user)

Please, describe your problem here.
Have watched the video about 6 times carefully. Have gone as far as deleting all my other users from previous work and only kept in the users from the import.

user batman@backendless.com

pass password (all lower case)

disabled user from Users data table

inspect > Network > error code 3090 confirmed.

Mission incomplete. Not sure why trigger isn’t working.


Hi Joshua,

Welcome to the Backendless community. The steps you described are valid. Could you please check if the API tracking is enabled in your app? You can find that setting on the Manage > App Setting screen in Backendless console:


Thanks Mark for your assist. My API tracking was enabled. :slight_smile:

My missions had been working just fine, even been accomplishing others, but now im at a roadblock with this one.

Could you please let me know your application ID? I’d like to take a look at the data in the database.



Everything looks good. Could you please try deleting that user accounts and repeating the steps again (including the csv import)

Hey Mark, I actually have tried that, I just tried it again just for you.

Still no response from the Missions.

I even tried using UI to do a login attempt, just in case. Cant get a response, but my inspection shows error code 3090. im baffled.

It is not right. I will get the task marked as completed manually so you can continue moving forward.

For the record, I understood how to Disable a user. :wink:

Thank you kindly, Mark! I appreciate you taking time out of your day for me. A pleasure to meet you as well. :slight_smile:

Hi Joshua,

Nice to meet you too.

Could you please check if the task is marked as complete now?


It is marked 4/4 complete on User Admin Tasks, but not displaying the thumbs up icon, in addition, the next stage, “Sheriff”, is not unlocked.

Hi @Joshua_Stockbridge,

I have marked this mission as completed.
Apologize for this problem, we need time to figure out what happened, I hope this will not happen again. For now, you can continue to complete missions further.
Thanks for reporting this issue!

Please let me know if you can continue moving forward with the missions.


Im starting to think there is something up with my user menu?

Im on Sherrif missions now under User Roles, and I made roles of Driver and Passenger. Mission complete.
Then I go to the second one and assign Driver to Batman and Passenger to Captain America.
Nothing, mission isnt triggering.

I’m baffled, Ive check it over a ton of times now.

Not certain if this will help, but in the next mission Invoke API using user account with custom role

I am getting an error 3011 when attempting to POST with Batman.

and then code 3030 when I attempt to delete with him:
||message: Unable to update user. User cannot be located for this version|

Not sure if its related or im just doing something wrong. But i went over the POST code character by character.


Hi @Joshua_Stockbridge,

I figured out why you are unable to complete these tasks. The problem is that in the Users table the email column is named with a capital letter (for some reason) - did you rename it? The column name is related to how mission progress is tracked.
To move further, rename the email column so that it starts with a small letter, and also reassign the custom roles (I removed the ones that are assigned now).

Please let me know if you succeed.


Ah! Crazy! I could swear I did not capitalize, but then you’d be relying on my memory. :rofl:

So sorry it was such a little thing!

No problem at all, I’m very glad we managed to resolve this issue, and now you’re able to move forward!