Support Topics Documentation Slack YouTube Blog

The exporting is broken


(rami saleem) #1

Hello Backendless Team,

Actually we have an issue with the exporting functionality, when I try to export any tables, I get the green message that says the process is running, but nothing will be displayed under the exporting folder, or send by email.

it was working fine before 6 weeks, but not now.

Can you check please?

Thanks,


(Mark Piller) #2

Hello Rami,

Could you please let us know what environment it is in (Dev, Stage or Prod). Also, please specify the app id that you tried to export.

Regards,
Mark


(rami saleem) #3

Production environment, I am trying to export the users table under “MobileBank” app.


(Mark Piller) #4

Could you please let me know if Aram checked whether the taskman process is running?


(rami saleem) #5

Yes, he checked it out, and didn’t fond anything not normal there.


(Mark Piller) #6

Try restarting the taskman process. Also, connect to your redis using redis-cli and run the following command:

llen bklsTasks

let us know what the command shows.


(rami saleem) #7

Aram did this today, still the same issue.


(Mark Piller) #8

Please see my question in the previous post - what does the following command from redis show:

llen bklsTasks


(rami saleem) #9

@Aram Yegenian Can you check please?


(Aram Yegenian) #10

Hi Mark,

I connected to config.redis.taskman.host, is that the correct redis server? Since we have split them into 13 separate servers, and I got the following result:

+OK

llen bklsTasks

:0


(Mark Piller) #11

Hi Aram,

Zero indicates there are no tasks in the queue - taskman has processed all of them. When you request an export, if the email still does not arrive, please check if there are any errors in the log (see the taskman log). Also, please check if the export file appears in the /export directory in the file repo of the app.

Regards,
Mark


(rami saleem) #12

Hello Mark,

The email not received, and the file not under the /export directory, as you can see below last exported file was on Nov-21.

Thanks,


(Mark Piller) #13

Thank you for checking, @rami-saleem. Please see my comment from a post above:

The clue as to why it is not working should be in the log.

Regards,
Mark


(rami saleem) #14

Can you check the logs please?

Let’s work on this together on Slack.

Thanks,


(Mark Piller) #15

Are you asking Aram, @rami-saleem ? We do not have access to your production system and cannot check the logs.


(rami saleem) #16

Yes, I am asking Aram, also Rustem has already access there.