Support Topics Documentation Slack YouTube Blog

Timer not send push notification as scheduled

Hi,

I’m recently facing a difficulty issue that Timers does not send push notification as daily schedule. However, if I navigate to Business Logic -> Timers -> Production and manually click run, my iPhone can receive push message properly.

my app id: 9BBF2D71-D06D-82C9-FF75-2DA7CC9FC800

Thanks for your help
Norawich T.

I need an answer can anyone help?

Hi, Norawich,

Can you send us your timer code on support@backendless.com ?
Thanks

Is the problem specifically with daily timer?
Did you try to set up an every minute or an every hour timer to check that you’ve done everything correctly?

I did a try and confirm it’s the issue on daily timer, then i used a workaround by applying the custom sec every 86400

Thanks

Hi, Norawich!
Yes, I’ve tested it too - there is a problem with daily timer. We’ve opened an internal ticket to solve that issue and we’ll notify on when it is done.

Assigned tag BKNDLSS-12146

Hi Norawich

Did you try to run timer manually?

Best, Artur.

Hi!

This issue fixed. Could you try it again?

I found this old topic, don’t want to open new, I have same problem, I set up push notification template, set timer, deploy it, it doesn’t run at scheduled time. When I run manually it doesn’t send push notifications.

Here is my timer code and log and app id E06560C6-0B4C-05DF-FF4E-5A1AFAD4EB00.

/**

  • Scheduled_Push_newTips timer.

  • It is executed according to the schedule
    */
    Backendless.ServerCode.addTimer({

    name: ‘Scheduled_Push_newTips’,

    startDate: 1615366800000,

    frequency: {
    schedule: ‘daily’,
    repeat: {
    ‘every’: 1
    }
    },

    /**

    • @param {Object} req
    • @param {String} req.context Application Version Id
      */
      async execute(req){

/BLOCKLY/ await Backendless.Messaging.pushWithTemplate(‘newTips’);
/BLOCKLY/
}
});

12:37:09 | SERVER_CODE | INFO | [18331] Building ServerCode Model for path (/opt/backendless/repo/e06560c6-0b4c-05df-ff4e-5a1afad4eb00/files/servercode/CODELESS/scheduled_push_newtips/PRODUCTION)

12:37:09 | SERVER_CODE | INFO | [18331] ServerCode Model built in 7ms

12:37:09 | SERVER_CODE | INFO | [18331] [62CF5F95-5BF7-4651-969F-448329E4E3C1] [INVOKE TIMER] Scheduled_Push_newTips

12:37:09 | SERVER_CODE | INFO | [18331] Processing finished in 175.426ms

Hi, @DB_Tower

I checked the (daily) timer in one of my apps and could not reproduce the issue. In both cases, the timer sent a message to the device (manual start and scheduled).
As I see from the timer history in your app, the timer Scheduled_Push_newTips ran several times today.
According to the log of this timer, it is also running (there are logs of timer starts).

Can I ask you to test it now? Do you experience this problem now? If yes, can I register my device in your app and test it manually?

Regards, Marina

Hi Marina,

Yes sure, you can register and test.
We will promote new version of our android app in next days, so maybe it’s some problem with mobile app, but I think push notification worked several days ago.

Regards,
Nikola