Twitter login popup doesn't close

Backendless Managed version and javascript sdk 5.9.1

I followed the instructions on the docs to login with twitter and the popup appears properly, I can authorize the app, but then the popup doesn’t close and only displays the ok message in json format.

I’ve tried multiple ways and always get the same result, here’s the actual code (vuex action)

login: async ({ commit }) => {
	const user = await Backendless.UserService.loginWithTwitter(undefined, true)

Hi Hendy,

What is your managed installation? Please specify the URL of the cluster.


Is this the one you need ?

Thanks, Hendy. This is not Managed, it is the Backendless Cloud service.

Could you please check if there are any errors in browser’s Console tab?


None, I have a console.log just below to check if it returns anything but it’s undefined.

Also I tried with a then -> catch, but it doesn’t trigger the catch either.

I wonder if removing async/await would make any difference? The popup comes from Twitter, so there is very little control we have over it…

Same result, I cannot get the data back to the site as the popup doesn’t close and give us a response, any ideas what it could be or similar questions posted before that could help us? Thanks!

Backendless.UserService.loginWithTwitter(undefined, true)
		.then(user => {
		.catch(err => console.error(err))

Just to make sure… have you go through the setup on the Twitter side as described here?: