Unable to add or update column values using REST API

I create a new table called Test. I created a new column called testcolumn of type INT. I use the REST interface to make the following request.

“isolationLevelEnum” : “READ_COMMITTED”,
“operations”: [
“operationType”: “CREATE”,
“table”: “Test”,
“payload”: {
“testcolumn”: 5

I get the following response
“created”: 1644882655000,
“testcolumn”: null,
“___class”: “Test”,
“ownerId”: null,
“updated”: null,
“objectId”: “A6113E0B-3D4E-4A84-B506-4B1D386C94F1”

I can never create the right value in the testcolumn. I have tested both int and string column types.

Also tried this by calling REST endpoint from python script - same problem. Am I setting up table wrong? Can you replicate?


I just ran a request against your database using Advanced REST Client and it worked just fine (you can see the created record in your database):

Thank you. That works!

My mistake was that I was using the URL https://…backendless.app/api/data/Test because that was in the REST Console. The GET and Delete functions work in the REST Console but the POST and PUT methods don’t seem to update the fields properly. Not sure if this was intended or not, but if not I hope it helps you. Thanks

the REST Console doesn’t support Transactions API. It works only with the basic CRUD.

1 Like