Support Topics Documentation Slack YouTube Blog

Unable to change "Owner Policy" for Users table


(Christopher Parker) #1

Application ID: D22BAE25-F356-BB5B-FF10-55A16389CF00
Error UID: 6D971377-8F96-91BC-FF1D-224632C66A00

Problem description

I messed around a lot with permissions in the backendless console (sorry - I can’t be much more descriptive right now. If it’s a setting, I probably touched it…) and eventually tried to update the “owner policy” for my users table… I disabled “find” access, and have been unable to turn it back on. Every time I do, I get the same error. (id logged above)

I am also having issues getting the currently logged in user in my application, which I suspect is related. (Error there is “User has no permission to find elements in persistence storage.” - 1013)

I tried refreshing, and logging out/back in to see if it was anything weird with my session, but that did not help - I still can not change the “owner policy” for the table. I’ve also tried reverting a lot of my other settings back to default, to no avail.

Steps to reproduce

Please describe steps to reproduce starting from the first action.

  1. Open the backendless console after logging in
  2. Go to the “Data” tab - it should default to the users table
  3. Go to permissions -> owner policy
  4. Click “find” (or any option) to enable the feature, then again to disable the feature.
  5. Click “find” again

Expected behavior: Feature should be re-enabled
Actual behavior: Feature stays disabled, and an error message pops up.


(Stanislaw Grin) #2

Hi Christopher,

thanks for reporting this issue!
I managed to reproduce the problem.
I created an internal ticket (you can refer to it by the following number - 18245) with a high priority for our engineer.
Soon he should fix this problem and will inform you here as soon as it is ready.

Regards,
Stanislaw


(Anton Govorushkin) #3

Hello @Christopher_Parker

We’ve released a fix for this issue, please verify

Anton


(Christopher Parker) #4

TI was able to confirm that this is now working. (This also solved my other issue with login)

Appreciate the quick turnaround; thank you!