Unable to create a custom function and can't upload a Favicon to a project

Backendless Version (Online)
Client SDK (JS/Codeless)
Application ID: ACE46687-EB31-F095-FF38-CDB1E0260900

When I try to create a custom function, I’m receiving the following error:
Oops. An internal error [67a6a61b24345831cd232c540f3560b3] has occurred. We are working on it. Please try again later

I’m also unable to upload a normal Favicon.ico under the settings to my project.
I always get the following error:
favicon file type is invalid, it must be one of [image/vnd.microsoft.icon]

The only problem is the file type that I’m trying to upload is a Microsoft Icon, and it’s only 4KB in size.

favicon.zip (214 Bytes)

Hi Michael,

There is a regression that prevents users from creating custom functions. We’re working on getting it fixed asap.

As for the favicon file. What directory are you trying to upload it to? I checked the /web folder in your app and I see the file is already there:


Thanks for letting me know about the custom function issue. A Backendless customer never knows if he’s the only one experiencing an issue (or not) :slight_smile:

I originally tried uploading it from the UI Builder > Settings page - under Favicon, but whatever I chose, it wouldn’t upload. I kept getting the above error. I tried an .ico file with a 16x16 image and various image formats (16 color, 256 color, and RGBA) none of them seem to work.

So I tried to copy it over manually, still no joy – still no icon on the tab.

What is the full URL of the page where you would like to see the fav icon?

The custom URL is: https://mgr.accofg.com/
The actual URL is: https://app.webmojo.io/api/files/web/accocontacts/index.html

For one thing, I just noticed that in the main app page: index.html, I see the following line:

<link rel="icon" href="data:,">

Hi @Michael_Kadron

The issue with creating custom UI function BKNDLSS-31687 has been fixed

According to the issue with Favicon, I just tried to modify it in my app and it works properly for me.

Could you please attach your favicon as a file and we will try it from our side?

didn’t see that you already attached the favicon file, I am trying to reproduce it


I just tried to upload your favicon into my app and it works well

after uploading the favicon in the Settings screen

  • does it stay pleced in the UI Container after refresh the browser page?
  • can you see it when you open the app in the preview mode?

Hey Vlad,

The upload still does not work for me.

The same error is shown:

I am still trying to upload the favicon.ico that was in my zip file.

This is still present in the index.html page:
<link rel="icon" href="data:,">

No, the favicon doesn’t show up anywhere.


I just tried uploading your favicon file and didn’t see any problems:

I could see that you added the icon to the default folder container.

I removed it and tried it again (from the default container), and I got the same error message that I reported previously.

There’s clearly a problem here. I’ve tried it with both Edge and Chrome and I get the same behavior with both.

Which browser are you using?


From “Mark Piller via Backendless Support” <support-forum@backendlessmail.com>
To “Michael Kadron” <mike@hyperpixels.net>
Date 3/9/2023 12:52:11 PM
Subject [Backendless Support] [Bug] Unable to create a custom function and can’t upload a Favicon to a project

Here are the errors in the console:

Here’s a video showing what I am doing. I tried it for both hyperpixels and the default UI containers:

That’s exactly what I’m doing, but not with the same results.
I can navigate to the Default or the Hyperpixels containers and click on the “Upload New” button and choose the same favicon.ico that I sent you, and I still get the error.

I attached the console errors in the post above.

But I have trusty Windows 11, not Mac.

That must be the problem :slight_smile:

Where I’ve tried it unsuccessfully from the BE Console, the following line is in the index.html file:
<link rel="icon" href="data:,">

Where you did it successfully, the following line is in index.html:
<link rel="shortcut icon" href="./favicon.ico?v=0acd7fd4" type="image/ico">

Could you please find the failing PUT request in the Network tab of the DevTools and export it as a curl command? It will be interesting to compare with mine to understand what the differences are.

I emailed it to you, Mark.

Closed as fixed.

Yay! :slight_smile:

Thank you Olha!


From “Olha Danylova via Backendless Support” <support-forum@backendlessmail.com>
To “Michael Kadron” <mike@hyperpixels.net>
Date 3/13/2023 9:59:55 AM
Subject [Backendless Support] [Bug] Unable to create a custom function and can’t upload a Favicon to a project