Support Topics Documentation Slack YouTube Blog

Unable to deploy code to application

Backendless Version (3.x / 5.x, Online / Managed / Pro )


Client SDK (REST / Android / Objective-C / Swift / JS )


Application ID


Expected Behavior

When doing “npm run deploy” it should deploy.

Actual Behavior

When doing “npm run deploy” it shows this:

More Details

It hangs for a long time in the step “Publishing Model to Server”.
It is running great on debug mode.

Hi Ricardo,

apologize for the inconvenience.
Please, few minutes, we’ll fix it and let you know immediately.


The problem is fixed, please try to deploy again, should work fine.


Hi Stanislaw, thanks for the response! I tried again and I’m getting the same issue.

I tried deploying another service and it worked so it has to be something related to my service.

Could it be it because I’m using these two packages: “google-ads-api” and “nodemailer”?
It’s the only difference I see between the two services :thinking:

Hi Ricardo!

Internal ticket BKNDLSS-20384 was created for this problem. We let you know when problem will be fixed.


@rmaturi when you deploy code with a lot of dependencies it will be deployed for some time. We have increased timeout and you shpuld be able to deploy the service