Unable to read from external API

Hi - I am connecting backendless to GET data from bubble’s api. I am able to authenticate successfully but unable to read the data which is formatted in json format.

the json is in this format which I am attempting to retrieve.

I am getting

I believe it has something to do with the indexing but I have tried everything I can. Please help.

This should explain why you’re getting an error:

Great. Looks like that was it but I need to return all objects from the list. Any guidance?

Just assign the result of the HTTP/s block to a variable. It will contain the list.

Very close on building my solution.
Looks like I am able to get the list now but just stuck writing that to DB. It needs an array it says.

Just pass apidata as the argument for the objects connector… :wink:

I only need a few fields from that array list.

Use the list filtering block to get only the properties you need for each object. Here’s a video describing how list filtering works in Codeless:

I think this one is only for filterting the data and not the columns. For eg, I only want acct_no and not item_no to be mapped to the database.


Did you watch the video I referenced?

Yes, but it doesn’t filter the columns (it only filters the data), unless I am doing something wrong.

all I need is insert acct_no data values and ignore the rest of columns from json.

This is the logic you need:

I think I tried that before. I just tried it again but it always insert all the columns. BTW, thank you for your remarkable help.

Hello @AD

just use Map instead of Filter

Awesome. That did it. Thank you very much.