Support Topics Documentation Slack YouTube Blog

Unstable business code and services behaviour


(Vladislav Kolegov) #1

Backendless Version (3.x / 5.x, Online / Managed / Pro )

Backendless 5.2.0 Online

Client SDK (REST / Android / Objective-C / Swift / JS )

REST, Swift

Application ID

3694DC88-F7D2-CE48-FFD3-60760A63BF00

Problems

OK, so I used codeless to create some business logic methods.
I used those methods in my app and everything worked as expected for several days at least.
But today one of those method invocations threw an error with a message “Model Descriptor not found”.
I tried using business logic REST console passing the same parameter and got the same error.
So I went to visual logic editor and re-deployed that method. It was successfully re-deployed according to message shown.

But when I went back to test it again, whole service dissappeared from ‘API Services’ tab!

I was slightly shocked, but decided to wait a little remembering of recent database maintenance, where some data were inaccessible for a short amount of time.
Nothing went back.
I started looking deeper and found my code in ‘Coding’ tab.
Tried to deploy it, popup message said it was successful but again, nothing appeared.

After a short amount of time I tried to do it again and service finally appeared and I could execute it.
But now it behaves very unstable. Very often it goes 400 with a message ‘Task execution is aborted due to timeout’

This method really has only two consequent API requests inside using two different tables.
Nothing really heavy, well except maybe whereClause is kinda complicated (is has few sub-queries).

But then again, everything worked fine few days ago and that dissappearing service thing happened.


(Anton Govorushkin) #2

Hi,
I see two codeless services present in the API Services screen. Is it correct or some of them are still missing? If all of them are in place please do the following:

  1. Try executing your FIND request you are using inside your service code apart from business logic. Separate REST request would give us understanding of where the root of the problem is. When done - please reply with results

  2. Please let us know service/method which results in request execution timeout. Also specify should a logged in user be in request OR you are calling the method while not being authenticated?

  3. And finally are you facing timeouts always when calling service’s method or most of requests succeed?

Anton


(Sergey Chupov) #3

Hello Vladislav,

We were able to identify the problem: one of the servers had troubles with the network so that each request issues from it resulted in exactly 5+ seconds response, which from your perspective ends up as a timeout. The server has been removed from the balancer temporarily to investigate the problem. Therefore, there shouldn’t be any more timeouts now.

Thank you for your report and detailed descriptions, it really did help us in identifying the cause.


(Vladislav Kolegov) #4

Thank you very much for quick support and solving the problem!

I’m also very glad my descriptions helped you identify the problem.