Updating Object with GeoPoint - Error 7007


We have a problem concerning the update of data objects that have a GeoPoint as attribute. This affects an iOS App we have in the store as well as the current development of the Android version.

When changing an object with a GeoPoint attached we get the following error message:
Failed to create or update com.backendless.datamodel.GeoPoint to database (7007).

The iOS Version is still version 1.0, there are no changes. The same applies to the relevant code of the Android version. Do you have an idea why this is happening without any changes on our side?



Okay, the error is gone now. However, problems like this definitely will make us reconsider the choice of using Backendless. Seems like we have to build the backend on our own.

The latest iOS Backendless SDK is 3.0.27 version. You could get it via CocoaPods:
pod ‘Backendless’
or from ios-SDK github.

Also you could try our F36DataWithRelatedGeo sample which demonstrates how to work with related GeoPoint. And please investigate this doc.

For the record: I am using GeoPoints for some time now. On Android I tried it with the newest version of the SDK while the iOS App, since it is in the store, uses a slightly older version. However both apps showed the same error indicating the problem was not on the client side.

As I said, the error is gone now on both platforms. So I guess you can mark this as solved.