Upload a file using API Error 6007 The specified resource was not found

Hi guys

I’m doing the Upload a file using API tutorial with Rest API using Thunkable blocks, but the file superfast.html doesn’t get uploaded. Here are the blocks based on what I read on file uploading in the api doc.


Content-Type: multipart/form-data


What might be the problem here? Do I need to add a Body part? And how does Backendless knows where the local file is? I’ve saved it to the Download path but I’m not sure if it will read there. Also, the html file is empty in case that matters.

Hello, @Junwei_Fang.

Could you provide your App_id?

Regards, Nikita.

Hi Nikita, thanks for your reply! I’ve solved the problem with UI components:)

Hi @Junwei_Fang,
could you share your blocks that worked? I got a similar problem :wink:


I used the frontend UI builder, drag the file uploader button into the builder and upload a file with it and it works. Cheers.

so you switched from thunkable to the backendless ui builder?

Yes. Look at this thread, here Giorgio also uses the UI builder to solve some missions. Mark also confirmed that all the missions can be done using just Backendless components.

Thank you